summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPeter Mattern2024-04-24 12:26:45 +0200
committerPeter Mattern2024-04-24 12:26:45 +0200
commite4cfc99ae0eb60b1833ff8d32ec874ceaf7ba8a4 (patch)
tree3fc6bc3506b53e1aba093d99d48dee795a401c9e /PKGBUILD
parentae20b495e9f96dc7ce774c2087b633caa1a84412 (diff)
downloadaur-lxqt-themes-git.tar.gz
Miscellaneous updates
* upstream URL (homepage, VCS repo) * license string * conflicts (PKGBUILD variable) * improve pkgver()
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5666ec97889d..e3e6903e8bd2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,22 @@
_pkgname=lxqt-themes
pkgname=$_pkgname-git
-pkgver=r112.f1737e9
-pkgrel=2
+pkgver=2.0.0
+pkgrel=1
pkgdesc='Themes, graphics and icons for LXQt'
arch=('any')
-url='https://github.com/lxde/lxqt-themes'
-license=('LGPL')
+url="https://lxqt-project.org"
+license=("LGPL-2.1-only")
depends=('hicolor-icon-theme')
makedepends=('git' 'cmake' 'lxqt-build-tools-git')
provides=("$_pkgname")
-conflicts=("$_pkgname" "lxqt-common"{,-git})
-source=("git+https://github.com/lxde/$_pkgname.git")
+conflicts=("$_pkgname")
+source=("git+https://github.com/lxqt/$_pkgname.git")
sha256sums=('SKIP')
pkgver() {
cd $_pkgname
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git describe --always | sed "s/-/.r/;s/-/./"
}
build() {