summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoréclairevoyant2023-05-21 06:52:41 -0400
committeréclairevoyant2023-05-21 06:52:41 -0400
commita68797e2dc0ce9babc64511a24360cf55b8a39d4 (patch)
treea75eb3c8bd58f423ad34197048ddd5633a38c1eb /PKGBUILD
parentdfc6f2b7a0d2a09281cb23dd187b6c7c3f5341cd (diff)
downloadaur-ly2video-git.tar.gz
ly2video-git: update deps, build process, .gitignore; fix pkgver
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD53
1 files changed, 26 insertions, 27 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6d92e81fc73a..a6a85d1223b2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,32 @@
-# Maintainer: redtide <redtid3@gmail.com>
-# Contributor: Liam Greenough <beacon515@gmail.com>
-# Contributor: Limao Luo <luolimao+AUR@gmail.com>
+# Maintainer: éclairevoyant
+# Contributor: redtide <redtid3 at gmail dot com>
+# Contributor: Liam Greenough <beacon515 at gmail dot com>
-pkgname_=ly2video
-pkgname=${pkgname_}-git
-pkgver=r429.c63cc1b
+_pkgname=ly2video
+pkgname="$_pkgname-git"
+pkgver=0.5.0.r0.g41364ad
pkgrel=1
-pkgdesc="A script to generate a video from a Lilypond sheet music file"
-provides=('ly2video')
-conflicts=('ly2video')
-arch=('any')
-url="https://github.com/aspiers/ly2video"
-license=('GPL3')
-depends=('ffmpeg' 'lilypond>=2.15.41' 'python-midi' 'python-pexpect' 'python-pillow' 'python-pip' 'timidity++')
-makedepends=('git')
-source=('ly2video::git+https://github.com/aspiers/ly2video.git')
-sha512sums=('SKIP')
+pkgdesc="Generate videos from Lilypond sheet music files"
+arch=(any)
+url="https://github.com/aspiers/$_pkgname"
+license=(GPL3)
+depends=(ffmpeg lilypond python-mido python-pexpect python-pillow timidity++)
+makedepends=(git python-setuptools)
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("git+$url.git")
+b2sums=('SKIP')
+
+pkgver() {
+ git -C $_pkgname describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
build() {
- cd "${srcdir}/${pkgname_}"
- python3 setup.py build
+ cd $_pkgname
+ python setup.py build
}
+
package() {
- cd "${srcdir}/${pkgname_}"
- python3 setup.py install --root="${pkgdir}" --optimize=1
-}
-pkgver() {
- cd "${srcdir}/${pkgname_}"
- ( set -o pipefail
- git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
- )
+ cd $_pkgname
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
}