summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbartus2019-08-30 19:59:19 +0200
committerbartus2019-08-30 19:59:19 +0200
commitf8d6fad6a3e4fa5a1d60fcfb1f384649ece21c14 (patch)
tree380831e8ef8e49ec3b618e1c5344c22c07dc1818 /PKGBUILD
parent2d9a11ed12f7cb2a187aefd24e3b6d0d1e98c26c (diff)
downloadaur-f8d6fad6a3e4fa5a1d60fcfb1f384649ece21c14.tar.gz
Travis: downgrade to 2.5.0 preventing timeout.
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cbb15d9da20d..23baa9e4067a 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,6 +17,7 @@
pkgname=magma
pkgver=2.5.1
+((TRAVIS)) && pkgver=2.5.0 # downgrade to prevernt time out.
pkgrel=1
pkgdesc="Provides a dense linear algebra library similar to LAPACK but for heterogeneous/hybrid architectures, starting with current 'Multicore+GPU' systems (with CUDA)"
arch=('x86_64')
@@ -29,6 +30,7 @@ makedepends=('gcc-fortran' 'cmake' 'cuda')
options=('staticlibs')
source=("http://icl.cs.utk.edu/projectsfiles/${pkgname}/downloads/${pkgname}-${pkgver}.tar.gz")
sha256sums=('ce32c199131515336b30c92a907effe0c441ebc5c5bdb255e4b06b2508de109f')
+((TRAVIS)) && sha256sums=('4fd45c7e46bd9d9124253e7838bbfb9e6003c64c2c67ffcff02e6c36d2bcfa33')
_CMAKE_FLAGS=( -DCMAKE_BUILD_TYPE=Release
-DCMAKE_INSTALL_PREFIX=/opt/magma )
@@ -69,8 +71,10 @@ package() {
cp -ru ${srcdir}/magma-${pkgver}/example/* ${pkgdir}/opt/magma/example/
mkdir -p ${pkgdir}/opt/magma/testing
cp -ru ${srcdir}/magma-${pkgver}/testing/* ${pkgdir}/opt/magma/testing/
- mkdir -p ${pkgdir}/usr/lib/
- mv ${pkgdir}/opt/magma/lib/pkgconfig ${pkgdir}/usr/lib/
+ ((TRAVIS)) || {
+ mkdir -p ${pkgdir}/usr/lib/
+ mv ${pkgdir}/opt/magma/lib/pkgconfig ${pkgdir}/usr/lib/
+ }
mkdir -p ${pkgdir}/usr/share/licenses/magma
cp ${srcdir}/magma-${pkgver}/COPYRIGHT ${pkgdir}/usr/share/licenses/magma/LICENSE
}