summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMoritz2017-07-20 18:24:02 +0200
committerMoritz2017-07-20 18:24:02 +0200
commit8a4ef9979ac2f11c16b0b2f3d3c1d33f2e45012d (patch)
tree9bd6eafaa71b48252b08c5584d1032086ee3868d /PKGBUILD
downloadaur-magma-ctglab.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e217bfc0d688
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Moritz Schaefer <mail AT moritzs DOT de>
+
+pkgname=magma-ctglab
+pkgver=1.06
+pkgrel=1
+pkgdesc="MAGMA is a tool for gene analysis and generalized gene-set analysis of GWAS data"
+arch=('i686' 'x86_64')
+url="https://ctg.cncr.nl/software/magma"
+license=('GPL v3.0')
+depends=('gcc')
+source=("https://ctg.cncr.nl/software/MAGMA/prog/magma_v${pkgver}_source.zip")
+md5sums=('71b5942d1b15c02bede23c4cd0312a6e')
+
+build() {
+ cd "$srcdir"
+ make
+}
+
+package() {
+ cd "$srcdir"
+ mkdir -p $pkgdir/usr/local/bin
+ cp magma $pkgdir/usr/local/bin/magma-ctglab
+}