summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorQue Quotion2020-03-04 19:14:53 +0900
committerQue Quotion2020-03-04 19:14:53 +0900
commit231d8b3e857954e9de49f1a5766c75766888d64e (patch)
tree33270410b09f3577495c48b76fdf5b18332868b7 /PKGBUILD
parent8e76fa7af921d82159068405bb8aae9b15d1e98b (diff)
downloadaur-231d8b3e857954e9de49f1a5766c75766888d64e.tar.gz
Don't duplicate tidy scripts as executable scripts; actually install executable scripts
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 20c7a281b81f..00c0618cc783 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=makepkg-optimize
pkgver=18
-pkgrel=2
+pkgrel=3
pkgdesc='Supplemental build and packaging optimizations for makepkg'
arch=('any')
license=('GPL')
@@ -91,7 +91,8 @@ package() {
install -m644 -D -t ${pkgdir}/usr/share/makepkg/buildenv/ ${_buildenv[@]%.in}
# Executable finding scripts
- install -m644 -D -t ${pkgdir}/usr/share/makepkg/executable/ ${_executable[@]//-exec.sh.in/.sh}
+ for i in ${_executable[@]%.in}; do
+ install -m644 -D -T ${i} ${pkgdir}/usr/share/makepkg/executable/${i//-exec.sh/.sh}; done
# Supplemental Tidy scripts
install -m644 -D -t ${pkgdir}/usr/share/makepkg/tidy/ ${_tidy[@]%.in}