summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRaymond Li2020-01-18 20:05:56 -0500
committerRaymond Li2020-01-18 20:05:56 -0500
commit7f8da55d688d35ecb14e301760f00ec88f0a3d0f (patch)
tree23d3544b479794e0b218825508bbf197cebb25a3 /PKGBUILD
parent56c93d0e589ee2f86fea733385d8a8ae972572c1 (diff)
downloadaur-makro.tar.gz
Fix source links
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e2a0ffad1afe..5a4f83df0360 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,22 @@
-# Maintainer: James An <james@jamesan.ca>
+# Maintainer: Raymo111 <hi@raymond.li>
+# Contributor: James An <james@jamesan.ca>
# Contributor: Nick B <Shirakawasuna at gmail _dot_com>
pkgname=makro
pkgver=1.0
-pkgrel=5
+pkgrel=6
pkgdesc="A simple KDE4 frontend for Xnee and Xbindkeys."
arch=('i686' 'x86_64')
url="http://www.kde-apps.org/content/show.php/Makro?content=88647"
license=('GPL')
-depends=('kdelibs' 'xbindkeys')
+depends=('kdelibs4support' 'xbindkeys')
makedepends=('cmake' 'automoc4')
source=(
- "http://kde-apps.org/CONTENT/content-files/88647-$pkgname.tar.gz"
+ "https://github.com/Raymo111/makro/raw/master/$pkgname.tar.gz"
'patch'
)
-md5sums=(
- '43f286516fd24890b222054b3931d5fa'
- '7d51848f46784b1ac768a9ba16dd14ee'
-)
+sha256sums=('f3cd11acfd196197239b66e5cd3ab313881b42c950f6949ec75375c1f3b0d191'
+ 'fa85e695a376dbf16661e0f09a21ab05a4f1672afce3279062ac3ca028bd1768')
prepare() {
cd $pkgname
@@ -36,6 +35,7 @@ build() {
package() {
cd $pkgname
- cmake -D CMAKE_INSTALL_PREFIX=`kde4-config --prefix` -D CMAKE_BUILD_TYPE=release --build build .
+# cmake -D CMAKE_INSTALL_PREFIX=`kde-config --prefix` -D CMAKE_BUILD_TYPE=release --build build .
+ cmake -D CMAKE_BUILD_TYPE=release --build build .
make DESTDIR=$pkgdir install
}