summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorViktor Drobot2022-01-20 21:05:01 +0300
committerViktor Drobot2022-01-20 21:05:01 +0300
commitee40d90d40d4e0a93dee65ba0f22a07f3f85d9b3 (patch)
treed4ae0653bdfdb883e30a61810f571c6ddb4f1798 /PKGBUILD
parent0fdeded863e683e38c97f316c0858d62b68c0126 (diff)
downloadaur-man-pages-ru.tar.gz
Update pkgbuild
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 11 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0d8b49773830..210a4ceb886d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,23 +4,28 @@
pkgname=man-pages-ru
pkgver=5.03_2390_2390_20191017
+_pkgver=${pkgver//_/-}
pkgrel=1
pkgdesc="Russian Linux man pages"
arch=(any)
url="https://sourceforge.net/projects/man-pages-ru/"
depends=(man)
-license=('FDL')
-source=(http://downloads.sourceforge.net/project/man-pages-ru/man-pages-ru_${pkgver//_/-}.tar.bz2)
+license=(FDL)
+source=(http://downloads.sourceforge.net/project/man-pages-ru/man-pages-ru_${_pkgver}.tar.bz2)
sha256sums=('ebe3b9ecc6d3faba607d82eeb174f565588ddd2e2ff5b599958d109f11965f5a')
package() {
- cd "$srcdir"/man-pages-ru_${pkgver//_/-}
- mkdir -p "$pkgdir"/usr/share/man/ru
- mv man* "$pkgdir"/usr/share/man/ru/
- cd "$pkgdir"/usr/share/man/ru
+ cd "${srcdir}"/man-pages-ru_${_pkgver}
+
+ mkdir -p "${pkgdir}"/usr/share/man/ru
+ mv man* "${pkgdir}"/usr/share/man/ru/
+
# this is included in shadow
+ cd "${pkgdir}"/usr/share/man/ru
+
rm -f man5/passwd.5*
rm -f man3/getspnam.3*
+
find . -type d -exec chmod 0755 {} \;
find . -type f -exec chmod 0644 {} \;
}