summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJesse McClure2017-03-06 19:07:01 -0500
committerJesse McClure2017-03-06 19:07:01 -0500
commitdbc56b13ca0500395942c779ef481b7036abf39d (patch)
tree21ee35aeb78201cbc8733c8610132e0ec94479da /PKGBUILD
parent03573f13d7d26428e6edd77893975df2110bcee6 (diff)
downloadaur-manaplus-git.tar.gz
removed physfs; switched to sdl2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e3bc1ded5e1b..d5657d77a14a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,26 +2,26 @@
# Contributor: Dan Sagunov <danilka.pro@gmail.com>
_gitname="manaplus"
pkgname="${_gitname}-git"
-pkgver=8335.ba2ad81
+pkgver=1.7.3.4.r21.g65d1cadca
pkgrel=1
pkgdesc="ManaPlus GIT version."
url="http://manaplus.evolonline.org"
arch=('i686' 'x86_64')
license=('GPL2')
-depends=('libxml2' 'physfs' 'sdl_image' 'sdl_mixer' 'sdl_net' 'sdl_ttf' 'sdl_gfx' 'mesa' 'curl')
+depends=('libxml2' 'sdl2_image' 'sdl2_mixer' 'sdl2_net' 'sdl2_ttf' 'sdl2_gfx' 'curl')
conflicts=('manaplus')
source=("${_gitname}::git://github.com/ManaPlus/ManaPlus.git")
sha256sums=('SKIP')
pkgver() {
cd "${_gitname}"
- echo "$(git rev-list --count HEAD).$(git describe --always)"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
cd "${_gitname}"
autoreconf -i
- ./configure --prefix=/usr
+ ./configure --prefix=/usr --with-sdl2
make
}