summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbirdflesh2015-06-09 19:51:01 +0300
committerbirdflesh2015-06-09 19:51:01 +0300
commite271e950800e2c6b068329094579f11e9da26087 (patch)
treeda75fc2105d821ea4227404211456c96b38efb81 /PKGBUILD
downloadaur-mangonel.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9d5c40084ba3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: birdflesh <antkoul at gmail dot com>
+
+pkgname=mangonel
+pkgver=1.1
+pkgrel=1
+pkgdesc="A simple and pretty application launcher for KDE"
+arch=('i686' 'x86_64')
+url='https://projects.kde.org/mangonel'
+license=('BSD')
+depends=('kdebase-runtime')
+makedepends=('cmake' 'automoc4')
+source=("http://download.kde.org/stable/$pkgname/$pkgname-$pkgver.tar.xz")
+md5sums=('5d2cabafcddd054e04f62dedcce4c156')
+
+build() {
+ cd "$srcdir"
+ mkdir build
+ cd build
+ cmake ../$pkgname-$pkgver \
+ -DQT_QMAKE_EXECUTABLE=qmake-qt4 \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/build"
+ make DESTDIR="$pkgdir" install
+ install -Dm644 "$srcdir/$pkgname-$pkgver/COPYING" "$pkgdir/usr/share/licenses/$pkgname/LICENCE"
+}