summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichael Polidori2019-09-19 06:59:27 -0400
committerMichael Polidori2019-09-19 06:59:27 -0400
commitdd84e7dffbe5384e8daed96eb30876f9744f577c (patch)
treea4dae5a6d3fc91e481301f57de9af06e2a45f953 /PKGBUILD
parente041cc88fc844868c5f044de688b8700f9cc314c (diff)
downloadaur-manly-git.tar.gz
fix pkgver and add provides and conflicts
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 4 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5d32e65fd7d2..6d0af53bcd7d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,22 +3,21 @@
pkgname=manly-git
_name=manly
-pkgver=r101.77d25dd
+pkgver=0.4.0.r12.b9ade3a
pkgrel=1
pkgdesc="A compliment to the man pages."
url="https://github.com/mpolidori/manly"
depends=('python')
license=('MIT')
arch=('any')
+provides=("$_name")
+conflicts=("$_name")
source=('git+https://github.com/mpolidori/manly.git')
md5sums=(SKIP)
pkgver() {
cd "$_name"
- ( set -o pipefail
- git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
- )
+ printf "%s" "$(git describe --long --tags | sed 's/^v//;s/\([^-]*-\)g/r\1/;s/-/./g')"
}
package() {