summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authordreieck2023-06-02 11:11:51 +0200
committerdreieck2023-06-02 11:11:51 +0200
commitf155e80ed5f41bd6b83d8f6d812572a5a2d6ab67 (patch)
tree10bdb3b56cf318006a248087b9eb88c074ae5b7d /PKGBUILD
parent4719b97a4c556507fced98c443289a43da65574e (diff)
downloadaur-marble-restricted-maps-git.tar.gz
Changed to a transitional package.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD43
1 files changed, 22 insertions, 21 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d419b64c3784..6de538684bef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,30 @@
-# Maintainer: sekret, mail=$(echo c2VrcmV0QHBvc3Rlby5zZQo= | base64 -d)
+# Maintainer: dreieck (https://aur.archlinux.org/account/dreieck)
+# Contributor: sekret (https://aur.archlinux.org/account/sekret)
+
_pkgname=marble-restricted-maps
-pkgname=$_pkgname-git
-pkgver=latest
-pkgrel=4
-pkgdesc="Maps for the Marble desktop globe with restricted licenses"
+pkgname="${_pkgname}-git"
+pkgver=1.0
+pkgrel=1
+pkgdesc="Transitional package to transition to 'marble-restricted-maps', which now is a metapackage that depends on the individual packages that used to be directly included in this package."
arch=('any')
url="https://gitlab.com/marble-restricted-maps"
-license=('unknown')
-depends=('marble-common')
-makedepends=('git')
-provides=("$_pkgname")
-conflicts=("$_pkgname")
-source=('git+https://gitlab.com/marble-restricted-maps/googlemaps.git'
- 'git+https://gitlab.com/marble-restricted-maps/googlesat.git'
- 'git+https://gitlab.com/marble-restricted-maps/virtualearth.git'
- 'git+https://gitlab.com/marble-restricted-maps/virtualearthos.git')
-md5sums=('SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP')
+license=('custom: metapackage')
+depends=(
+ "marble-restricted-maps"
+)
+makedepends=()
+provides=()
+conflicts=()
+replaces=()
+source=(
+ 'license-metapackage-pd.txt'
+)
+sha256sums=(
+ 'af68dd29515606a94237214e4c33b0e3f4f2408ed92df3674a043bf2fa2c0078'
+)
package() {
- mkdir -p "$pkgdir/usr/share/marble/data/maps/earth"
- cp -r * "$pkgdir/usr/share/marble/data/maps/earth"
- find "$pkgdir/usr/share/marble/data/maps/earth" -name '.git' | xargs rm -rf
+ install -D -v -m644 "${srcdir}/license-metapackage-pd.txt" "${pkgdir}/usr/share/licenses/${pkgname}/copying.public-domain.txt"
}
# vim:set ts=2 sw=2 et: