summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRubin Simons2025-01-01 15:58:06 +0100
committerRubin Simons2025-01-01 15:58:06 +0100
commit0f401fd3cdc149bb7f362b56a51b601b030a7d79 (patch)
tree2eaf81ffedc12e4719cffc28b23127d2ef3dec3c /PKGBUILD
downloadaur-marksman-git.tar.gz
Initial version of marksman-git
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..83ddcb88bdfe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Rubin Simons <me@rubin55.org>
+
+# Note: change to main when .net9 work merges
+_branch=artempyanykh/stack/8
+_pkgname=marksman
+pkgname=${_pkgname}-git
+pkgver=r477.92d3db3
+pkgrel=1
+pkgdesc="Write Markdown with code assist and intelligence in the comfort of your favourite editor."
+arch=('any')
+url="https://github.com/artempyanykh/${_pkgname}"
+license=('GPL')
+makedepends=('dotnet-sdk' 'git')
+depends=('dotnet-runtime')
+options=('!strip')
+source=("${pkgname}::git+${url}.git#branch=${_branch}")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${pkgname}"
+
+ # Disable dotnet telemetry
+ export DOTNET_CLI_TELEMETRY_OPTOUT=1
+
+ dotnet build --configuration Release Marksman.sln
+ dotnet publish --configuration Release Marksman.sln --output "$PWD"/publish
+}
+
+package() {
+ mkdir -p "$pkgdir"/usr/lib
+ mkdir -p "$pkgdir"/usr/bin
+ cp -dr --no-preserve='ownership' ${pkgname}/publish "$pkgdir"/usr/lib/marksman
+
+ ln -s /usr/lib/marksman/marksman "$pkgdir"/usr/bin/marksman
+}