summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBrayden Banks2018-07-18 13:19:29 -0700
committerBrayden Banks2018-07-18 13:19:29 -0700
commit1abb98d2947d54978844c59b6ed717d44e3bf6d8 (patch)
tree11876ed0058b2d220457e0ce28a04570436c8116 /PKGBUILD
downloadaur-mastodon-backup-git.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..479d34070815
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: bb010g <bb010g@bb010g.com>
+pkgname=mastodon-backup-git
+pkgver=r146.afc28dd
+pkgrel=1
+pkgdesc="Archive your statuses, favorites and media using the Mastodon API (Git version)"
+arch=(any)
+url="https://github.com/ponylang/mkdocs-theme"
+license=('GPL3')
+depends=(python python-{html2text,mastodon,progress})
+makedepends=(git python-setuptools)
+source=("git+https://github.com/kensanata/${pkgname%-git}")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}