summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJP-Ellis2019-04-18 14:25:57 +1000
committerJP-Ellis2019-04-18 14:25:57 +1000
commit495943ea0424e7e14ba987bbc4c47aa620f55e62 (patch)
tree13b00e9837d42fa5c3df24e45263a7d033b75ba9 /PKGBUILD
parent1a5f949c89810814d212cf49e2754bf6f317f727 (diff)
downloadaur-495943ea0424e7e14ba987bbc4c47aa620f55e62.tar.gz
Adjust warnings
Signed-off-by: JP-Ellis <josh@jpellis.me>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 3 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8a45ff6f1ac8..941d29bb9fb0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -92,16 +92,13 @@ options=("!strip")
PKGEXT='.pkg.tar'
prepare() {
- if df "${srcdir}" | grep -q tmpfs; then
- warning "Building Mathematica takes more than 8GB of space."
- warning "Building in a tmpfs (e.g. /tmp when mounted into RAM) may not work."
- fi
+ warning "Building Mathematica takes more than 8GB of space."
+ warning "Building in a tmpfs (e.g. /tmp when mounted into RAM) may not work."
if [ $(echo "${srcdir}" | wc -w) -ne 1 ]; then
msg2 "ERROR: The Mathematica installer doesn't support directory names with spaces."
- msg2 "Try building from a directory without spaces."
msg2 "Current build directory: ${srcdir}"
- false
+ exit 1
fi
chmod +x ${srcdir}/Mathematica_${pkgver}_LINUX.sh