summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJP-Ellis2017-02-09 17:43:40 +1100
committerJP-Ellis2017-02-09 17:43:40 +1100
commit89e8504d361bd75886b2352ad909d8bb3d59df1d (patch)
tree785fd1803d33754c8c3f8e5b7309fa8d6d5bd911 /PKGBUILD
parentfef6d4536854395147be057e0b7743848ca7849f (diff)
downloadaur-89e8504d361bd75886b2352ad909d8bb3d59df1d.tar.gz
Separate preparation steps from packaging
Signed-off-by: JP-Ellis <josh@jpellis.me>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ae75916786ff..b0cf4332d629 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -25,8 +25,8 @@ PKGEXT=".pkg.tar"
# To build this package you need to place the mathematica-installer into your startdir
# If you don't own the installer you can download a trial version at http://www.wolfram.com/mathematica/trial
-package() {
- if df "${pkgdir}" | grep -q tmpfs; then
+prepare() {
+ if df "${srcdir}" | grep -q tmpfs; then
warning "Building Mathematica takes more than 8GB of space."
warning "Building in a tmpfs (e.g. /tmp when mounted into RAM) may not work."
fi
@@ -39,8 +39,9 @@ package() {
fi
chmod +x ${srcdir}/Mathematica_${pkgver}_LINUX.sh
+}
- echo "Running Mathematica installer"
+package() {
# https://reference.wolfram.com/language/tutorial/InstallingMathematica.html#650929293
${srcdir}/Mathematica_${pkgver}_LINUX.sh -- \
-execdir=${pkgdir}/usr/bin \