aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMarco Rubin2022-04-19 21:39:21 +0200
committerMarco Rubin2022-04-19 21:39:21 +0200
commit0d2e460d181c7d15115216f04d4435309b0aa9ce (patch)
tree71134266307d2e66fa23dbf2ff80d3f1b00fb5fd /PKGBUILD
parent6f93b85e0c3769322f1410c1edf1f679d9b14246 (diff)
downloadaur-0d2e460d181c7d15115216f04d4435309b0aa9ce.tar.gz
Update dependencies
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 25 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dd29510a951c..727d32a6353e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgbase=matlab
pkgname=('python-matlabengine' 'matlab')
-pkgrel=1
+pkgrel=2
# No need to modify the pkgver here, it will be determined by the script
# in the offline installer.
pkgver=9.12.0.1903524
@@ -16,26 +16,25 @@ makedepends=('findutils' 'gendesk' 'icoutils' 'python')
# Some of the dependencies probably are not needed.
# If you play around with them and find which one can be removed,
# please contact the maintainers.
+# For a list of possible dependencies, see here:
+# https://hub.docker.com/r/mathworks/matlab-deps/dockerfile.
depends=(
- 'ca-certificates'
- 'lsb-release'
'alsa-lib'
'atk'
- 'libcap'
- 'libcups'
- 'libdbus'
+ 'ca-certificates'
+ 'cairo'
'fontconfig'
- 'libgcrypt'
'gdk-pixbuf2'
+ 'glib2'
'gst-plugins-base'
'gstreamer'
- 'gtk2'
+ 'gtk3'
'krb5'
- 'nspr'
- 'nss'
- 'pam'
- 'pango'
- 'cairo'
+ 'libcap'
+ 'libcups'
+ 'libdbus'
+ 'libdrm'
+ 'libgcrypt'
'libselinux'
'libsm'
'libsndfile'
@@ -57,17 +56,27 @@ depends=(
'libxt'
'libxtst'
'libxxf86vm'
+ 'lsb-release'
+ 'make'
+ 'mesa'
+ 'net-tools'
+ 'nspr'
+ 'nss'
+ 'pam'
+ 'pango'
'procps-ng'
- 'xorg-server-xvfb'
- 'x11vnc'
'sudo'
+ 'unzip'
+ 'util-linux-libs'
+ 'wget'
+ 'x11vnc'
+ 'xorg-server-xvfb'
'zlib')
# We should check even these ones.
# GCC: https://www.mathworks.com/support/requirements/supported-compilers.html
depends+=(
'gconf'
'glu'
- 'gstreamer'
'libunwind'
'libxp'
'libxpm'