aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGrey Christoforo2018-12-19 21:29:40 +0000
committerGrey Christoforo2018-12-19 21:29:40 +0000
commitda02d2ce1b2266c699b7f88237d775728e1edad5 (patch)
tree0330aa254e8daccd89e41e60ace25065a70b75cf /PKGBUILD
parenta68e9763104f94564be0729d2d83c1178acb5be1 (diff)
downloadaur-da02d2ce1b2266c699b7f88237d775728e1edad5.tar.gz
fix up partial install
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 3 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 55eb67d2ca93..b7cdc0f0fef6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,7 +18,7 @@
#│   ├── matlabdata/
#│   ├── matlab_desktop_glnxa64_1535004605.enc*
#│   ├── matlab_desktop_glnxa64_1535004605.xml*
-#│   ├── ... other encrypted toolbox/related files & folders go here
+#│   ├── ... other toolbox/product files & folders go here
#├── bin/
#├── help/
#├── install*
@@ -35,9 +35,8 @@
## This PKGBUILD no longer attempts to activate the product.
## The user will be prompted to undertake their activation method of choice when the GUI is first run.
-## Activation could be automated by running /opt/matlab/bin/activate_matlab.sh
-## after this package is installed.
-## That activation script could be called by matlab.install (a file that doesn't exist at this time)
+## Activation could be automated by running /opt/matlab/bin/activate_matlab.sh after this package is installed.
+## Activation could be further automated in matlab.install (a file that doesn't exist at this time)
# partial install
_partialinstall=false
@@ -94,12 +93,8 @@ prepare() {
sed -i "s,^# mode=,mode=silent," "${srcdir}/installer_input.txt"
sed -i "s,^# fileInstallationKey=,fileInstallationKey=${_fik}," "${srcdir}/installer_input.txt"
- # install all productcts by default
- sed -i "/^#product.${_product}$/ s/^#//" "${srcdir}/installer_input.txt"
-
if [ ! -z ${_products+isSet} ]; then
msg2 'Building a package with a subset of the licensed products.'
- sed -i "s,^product,#product," "${srcdir}/installer_input.txt"
for _product in "${_products[@]}"; do
sed -i "/^#product.${_product}$/ s/^#//" "${srcdir}/installer_input.txt"
done