summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWilliam Gathoye2019-09-13 20:29:32 +0200
committerWilliam Gathoye2019-09-14 00:09:53 +0200
commitb7959415393ac90773328038ef3e9d38fe5c2d9a (patch)
treeee3dd843c08ee2853efef8fb80de1c2e3fdc44c7 /PKGBUILD
parent5a269ea92ef49070119bb120bfa13972aa48bbef (diff)
downloadaur-mattermost-push-proxy.tar.gz
Upgrade to 5.9.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 10 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e24a1cdd4087..5d74a1f72a49 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
# Contributor: Janne Heß <jannehess@gmail.com>
pkgname=mattermost-push-proxy
-pkgver=5.4
-pkgrel=2
+pkgver=5.9.0
+pkgrel=1
pkgdesc='Mattermost Push Notifications Service'
arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://github.com/mattermost/mattermost-push-proxy.git"
license=("Apache")
-makedepends=('go-pie')
+makedepends=('go-pie' 'git')
provides=("${pkgname}")
conflicts=("${pkgname}-git")
backup=('etc/mattermost-push-proxy/config.json')
@@ -20,9 +20,9 @@ source=(
'mattermost-ldflags.patch'
)
sha512sums=(
- '498cd563538cff338e63e160828eb9b15a3b7e33ea7ae153f96de77cb72db3256c48607ebe7793a5f565009364259a306fecfb022f960b61a26682cd19c597c0'
+ '0ed61fc1aef2a7ccc2d0df78cb0fedf6367834bf4ab05619d51c47803936a83cab6ca2c1cb0b1458aa768780cbb36d2377e31715a169f77acf32a531c7a3a79a'
'6d646673f10d2e291d37bbfa53c0314f076922bf76ceadcecad8febb7ac377fedc1bbbc82d118e161ad662e1f363fb5ca0b3750a0601eedf56bdb9c5e084ede4'
- 'bcc6deb1afd470bccc9bea39a13497fbdc91d8108138dfb7e62a5bcf3569bc4b810121403e0f877ba91245d9bf95c254d28d5e826777e292c0bc9b358a79ba80'
+ '0a6311b07df33cb5bed1d9e9a442e62fa75136e36a8a6100388151f39017c6457bbc62cb80a36ceb284c4ef8916efe230f81ea0a81d21001ad212469d3f77f22'
)
install="${pkgname}.install"
@@ -33,6 +33,11 @@ prepare() {
ln -s "${srcdir}/mattermost-push-proxy-${pkgver}" "${pkgname}"
cd "${pkgname}"
+ # Testing the code with shadow breaks with Go 1.13, remove the test for now.
+ # src.: https://github.com/mattermost/mattermost-server/issues/12202
+ sed -r -iV Makefile \
+ -e "/[$]\(GOPATH\)\/bin\/shadow/d"
+
# Pass Arch Linux's Go compilation flags to Mattermost in order to take
# into account advanced features like PIE.
patch < "${srcdir}"/mattermost-ldflags.patch