summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFabioLolix2024-03-19 07:08:54 +0100
committerFabioLolix2024-03-19 07:08:54 +0100
commit8eff5b8eb703cdb2bd243264d90d9b6d1883c8a8 (patch)
tree06c01fba2743c7fb51738f43a95bf764282f52a9 /PKGBUILD
parentf111b3d4cbdd83b62dcfd798246d99753e54fec8 (diff)
downloadaur-mauikit-git.tar.gz
use qt6
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9f1f30c0ceb5..5151bae7b3d8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: Fabio 'Lolix' Loli <fabio.loli@disroot.org> -> https://github.com/FabioLolix
pkgname=mauikit-git
-pkgver=3.0.1.r64.g277a2870
-pkgrel=2
+pkgver=3.1.0.r8.gb2984f59
+pkgrel=1
pkgdesc='Utilities and "templated" controls based on Kirigami and QCC2 that follow the ongoing work on the Maui HIG'
arch=(x86_64 i686 armv7h aarch64)
url="https://mauikit.org/"
license=(LGPL3)
groups=(maui)
-depends=(qt5-base qt5-declarative qt5-quickcontrols2 knotifications5 ki18n5 mauiman-git)
-makedepends=(git cmake extra-cmake-modules qt5-webengine appstream syntax-highlighting5 plasma-framework5)
+depends=(qt6-base qt6-declarative qt6-quickcontrols2 knotifications5 ki18n5 mauiman-git)
+makedepends=(git cmake extra-cmake-modules qt6-webengine appstream syntax-highlighting5 plasma-framework5)
provides=(mauikit)
conflicts=(mauikit)
source=("git+https://invent.kde.org/kde/mauikit.git")
@@ -22,6 +22,7 @@ pkgver() {
build() {
cmake -B build -S "mauikit" -Wno-dev \
+ -DBUILD_WITH_QT6=ON \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr