summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMuflone2020-03-01 00:50:52 +0100
committerMuflone2020-03-01 00:50:52 +0100
commitb8e72cfdb5e1f410d76b5bf471e7e0504aa68a1e (patch)
tree9f13bc09ad86464ee47cde30ba16ac5f52f61b82 /PKGBUILD
parent91a6bdd0d9a22061658fb710224182f5fadb221e (diff)
downloadaur-mbrola-voices-br4.tar.gz
Updated package mbrola-voices-br4 15.6fa9693-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD57
1 files changed, 40 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7215f94e6521..dfabe48234dd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,47 @@
-# Maintainer: Muflone <webreg@vbsimple.net>
+# Maintainer: Muflone http://www.muflone.com/contacts/english/
+
pkgname=mbrola-voices-br4
-pkgver=1
-pkgrel=2
-_pkgfile=br4
+pkgver=15.6fa9693
+pkgrel=1
+_pkgfile="${pkgname/mbrola-voices-/}"
+_commit=6fa9693c09bc98f21a519dd9460340db964bacab
pkgdesc="A Brazilian Portoguese male voice for the MBROLA synthesizer"
-arch=(any)
-url="http://tcts.fpms.ac.be/synthesis/mbrola.html"
-groups=(mbrola-voices-br mbrola-voices gespeaker-mbrola-voices)
-depends=(mbrola)
-license=(custom)
-source=("http://tcts.fpms.ac.be/synthesis/mbrola/dba/${_pkgfile}/${_pkgfile}.zip")
-md5sums=('394f23408fba082975310f07eafa0205')
+arch=('any')
+url="https://github.com/numediart/MBROLA-voices/"
+groups=('mbrola-voices')
+depends=('mbrola')
+license=('custom')
+source=("https://github.com/numediart/MBROLA-voices/raw/${_commit}/data/${_pkgfile}/${_pkgfile}"
+ "https://github.com/numediart/MBROLA-voices/raw/${_commit}/data/${_pkgfile}/README.txt"
+ "https://github.com/numediart/MBROLA-voices/raw/${_commit}/data/${_pkgfile}/license.txt"
+ "https://github.com/numediart/MBROLA-voices/raw/${_commit}/data/${_pkgfile}/TEST/mbroli.ini"
+ "https://github.com/numediart/MBROLA-voices/raw/${_commit}/data/${_pkgfile}/TEST/como_como.pho"
+ "https://github.com/numediart/MBROLA-voices/raw/${_commit}/data/${_pkgfile}/TEST/music.pho"
+ "https://github.com/numediart/MBROLA-voices/raw/${_commit}/data/${_pkgfile}/TEST/tabela_de_notas.pho"
+ "https://github.com/numediart/MBROLA-voices/raw/${_commit}/data/${_pkgfile}/TEST/test.pho"
+ "https://github.com/numediart/MBROLA-voices/raw/${_commit}/data/${_pkgfile}/TEST/diphones_complete_listing.txt"
+ "https://github.com/numediart/MBROLA-voices/raw/${_commit}/data/${_pkgfile}/TEST/readme.txt")
+sha256sums=('c93fa66ebfab790bc255cb77499e7eca055ac1216df0f336fdcc2037c4271bbc'
+ '1d66e17556fd8b4d414904dd94efbef45e228b8429c61514f85e7299d908a11d'
+ '04bd516b8f998800e1811fa5fd4abb1956034ec5177185cfd6c9eb480bf208cc'
+ '016592ee6e9a86a4b6f2fb1cfd24ea47a83591f93ca1e4790a31f2cdc07433b7'
+ 'ef0025e913ceda1516fc04ccf4e403ed25be117a042e275880e51c105bde9dfa'
+ '0839ed23b01a6f7fa1ebddf860f9c309a48f7619a2f71f78fbfb904139ebf1bf'
+ 'e91b94916f0248ad48c09b2a54f041a038c04057e8b346661b496fa5aeaee4f0'
+ 'f98ca8b32e64d776e6532cec37fd3135fa132d1c9f218013f05d7d6a69fbd2c9'
+ '32df6d8f653081839412395c45d582c701763c513c5140b9b0d40448ce76e3fa'
+ '61c90d0e3773245d12b0164848ce4f7beb886d2d9d8a1352e095c2fc277e9eb7')
package(){
- cd "${srcdir}"
# Install license file
- install -D -m 644 "license.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -m 644 -D "license.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
# Install files
- for file in br4 br4.txt TEST/*
- do
- install -D -m 644 "${file}" "${pkgdir}/usr/share/mbrola/${_pkgfile}/${file}"
- done
+ install -m 755 -d "${pkgdir}/usr/share/mbrola/${_pkgfile}"
+ install -m 644 -t "${pkgdir}/usr/share/mbrola/${_pkgfile}" \
+ "${_pkgfile}" README.txt
+ # Install test files
+ install -m 755 -d "${pkgdir}/usr/share/mbrola/${_pkgfile}/test"
+ install -m 644 -t "${pkgdir}/usr/share/mbrola/${_pkgfile}/test" \
+ mbroli.ini como_como.pho music.pho tabela_de_notas.pho test.pho \
+ diphones_complete_listing.txt readme.txt
}