summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMuflone2020-04-04 01:47:47 +0200
committerMuflone2020-04-04 01:47:47 +0200
commit935cac1a72e2152b25bcd288b2153343dc88e7c3 (patch)
tree00da74ce744fce888351324f097f2c8a208f7272 /PKGBUILD
parentbc9f9b3842321716c4bd7801172e69bd4cbf2643 (diff)
downloadaur-mbrola-voices-it4.tar.gz
Updated package mbrola-voices-it4 1:15.6fa9693-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD50
1 files changed, 33 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c464a34215e7..a48a6f0f70bd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,41 @@
-# Maintainer: Muflone <webreg@vbsimple.net>
+# Maintainer: Muflone http://www.muflone.com/contacts/english/
# Contributor: Changaco <me@changaco.net>
+
pkgname=mbrola-voices-it4
-pkgver=010926
-pkgrel=3
-_pkgfile=it4
+pkgver=15.6fa9693
+pkgrel=1
+epoch=1
+_pkgfile="${pkgname/mbrola-voices-/}"
+_commit=6fa9693c09bc98f21a519dd9460340db964bacab
pkgdesc="An Italian female voice for the MBROLA synthesizer"
-arch=(any)
-url="http://tcts.fpms.ac.be/synthesis/mbrola.html"
-groups=(mbrola-voices-it mbrola-voices gespeaker-mbrola-voices)
-depends=(mbrola)
-license=(custom)
-source=("http://tcts.fpms.ac.be/synthesis/mbrola/dba/${_pkgfile}/${_pkgfile}-${pkgver}.zip")
-md5sums=('d70ddbda1085990290e98bf745db1536')
+arch=('any')
+url="https://github.com/numediart/MBROLA-voices/"
+groups=('mbrola-voices')
+depends=('mbrola')
+license=('custom')
+source=("https://github.com/numediart/MBROLA-voices/raw/${_commit}/data/${_pkgfile}/${_pkgfile}"
+ "https://github.com/numediart/MBROLA-voices/raw/${_commit}/data/${_pkgfile}/license.txt"
+ "https://github.com/numediart/MBROLA-voices/raw/${_commit}/data/${_pkgfile}/README.txt"
+ "https://github.com/numediart/MBROLA-voices/raw/${_commit}/data/${_pkgfile}/TEST/mbroli.ini"
+ "https://github.com/numediart/MBROLA-voices/raw/${_commit}/data/${_pkgfile}/TEST/sent1.pho"
+ "https://github.com/numediart/MBROLA-voices/raw/${_commit}/data/${_pkgfile}/TEST/sent2.pho")
+sha256sums=('807a3aba68209b154ce8d3d953165d06092023beee1186ec622c938a33f7692a'
+ '6fbad2ecaca000f631e9a2e4aac9ef872a5f1a8b037b718d5caea1290d376b97'
+ '63b097f860646c6a47a4cec004ff3354b85435a2efde56e0f849fc4cdba673aa'
+ 'a352e6f76fbbd28bdb231e48e1180f6e54e6f0053929c92941b5229292f5b016'
+ 'b8e85014479508fb60d921069d504cd6bce4ff6c057535149cb18abe9767d418'
+ 'de94a208d5a0cd7bcbf4eee3b743e76f419a3122f79ba1ffc456937b34156d0b')
package(){
- cd "${srcdir}/${_pkgfile}"
# Install license file
- install -D -m 644 "license.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -m 755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m 644 -D "license.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
# Install files
- for file in it4 it4.txt TEST/*
- do
- install -D -m 644 "${file}" "${pkgdir}/usr/share/mbrola/${_pkgfile}/${file}"
- done
+ install -m 755 -d "${pkgdir}/usr/share/mbrola/${_pkgfile}"
+ install -m 644 -t "${pkgdir}/usr/share/mbrola/${_pkgfile}" \
+ "${_pkgfile}" README.txt
+ # Install test files
+ install -m 755 -d "${pkgdir}/usr/share/mbrola/${_pkgfile}/TEST"
+ install -m 644 -t "${pkgdir}/usr/share/mbrola/${_pkgfile}/TEST" \
+ mbroli.ini sent1.pho sent2.pho
}