summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPierce Lopez2021-01-24 12:08:07 -0500
committerPierce Lopez2021-01-24 12:09:30 -0500
commit6d1fce991fa3fbea43b95463bdc4018d3a743695 (patch)
tree819c691e5d402e5f6b8329a0a96b7afa84ad1431 /PKGBUILD
parent21276a19bb6134760aaf9f62f4e31218eede923f (diff)
downloadaur-mbrowse.tar.gz
patch compiler error about bookmark_items
also patch warning about strncpy size in configuration load and bump rev to 5
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 13 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 18ee5da1c928..a08917fabea2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,24 @@
pkgname=mbrowse
pkgver=0.4.3
-pkgrel=4
+pkgrel=5
pkgdesc='A graphical SNMP MIB browser based on GTK+ and Net-SNMP'
arch=('i686' 'x86_64')
license=('GPL')
url='https://sourceforge.net/projects/mbrowse/'
depends=('gtk2' 'net-snmp')
-source=("https://sourceforge.net/projects/${pkgname}/files/${pkgver}/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('735a86a027659d3be39723d554758d6b51cce56ef3807efd5123d48ebf41506e')
+source=("https://sourceforge.net/projects/${pkgname}/files/${pkgver}/${pkgname}-${pkgver}.tar.gz"
+ "bookmark_items.patch"
+ "configuration_strncpy.patch")
+sha256sums=('735a86a027659d3be39723d554758d6b51cce56ef3807efd5123d48ebf41506e'
+ 'a6aad6155b9042d3f05a6d40fcb296d393fc84f036a6c73466ecd0f5183cb0de'
+ 'ee3788fe3c127e3aae42fe5ceefdb8437b7b859a313d10ef3f9e604015af0473')
+
+prepare() {
+ cd $pkgname-$pkgver
+ patch -p1 <$srcdir/bookmark_items.patch
+ patch -p1 <$srcdir/configuration_strncpy.patch
+}
build() {
cd $pkgname-$pkgver