summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChris Severance2022-12-16 14:51:30 -0500
committerChris Severance2022-12-16 14:51:30 -0500
commit3b65b81a13b830c988f3126ed6e1bb45ecf9f4be (patch)
treed3654a9a724531c25261ed9a5c0701256baefa85 /PKGBUILD
parentece51498f4d9236edd6f1607f473a5b98d557d84 (diff)
downloadaur-mdadm-git.tar.gz
autu: Update to 4.2.r61.g8b668d4a-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 20 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 72bbd5c7b2c7..240fa20bbdb2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,21 +7,25 @@
set -u
_pkgname='mdadm'
pkgname="${_pkgname}-git"
-pkgver=4.1.r106.ga64f126
+pkgver=4.2.r61.g8b668d4a
pkgrel=1
-pkgdesc='create, manage, and monitor Linux mdraid block device RAID arrays'
+pkgdesc='A tool for managing/monitoring Linux md device arrays, also known as Software RAID'
arch=('i686' 'x86_64')
#url='https://github.com/neilbrown/mdadm'
-url='http://neil.brown.name/blog/mdadm'
+#url='http://neil.brown.name/blog/mdadm'
license=('GPL')
-depends=('glibc')
+url='https://git.kernel.org/pub/scm/utils/mdadm'
makedepends=('git')
-#optdepends=('lvm2' 'dm-crypt' 'bcache')
+depends=('glibc' 'systemd')
+#depends+=('mkinitcpio>=0.7')
+optdepends=('bash: mdcheck')
+#optdepends+=('lvm2' 'dm-crypt' 'bcache')
provides=("${_pkgname}=${pkgver%.r*}")
-conflicts=('mkinitcpio<0.7' "${_pkgname}")
+conflicts=("${_pkgname}")
replaces=('raidtools')
backup=("etc/${_pkgname}.conf")
install="${_pkgname}.install"
+#validpgpkeys=('6A86B80E1D22F21D0B26BA75397D82E0531A9C91') # Jes Sorensen
_verwatch=('https://mirrors.edge.kernel.org/pub/linux/utils/raid/mdadm/' 'mdadm-\(.*\)\.tar\.xz' 't')
_archlink="@@@::https://projects.archlinux.org/svntogit/packages.git/plain/trunk/@@@?h=packages/${_pkgname}"
source=(
@@ -29,6 +33,7 @@ source=(
#"mdadm_gitnb::git://neil.brown.name/${_pkgname}"
#"mdadm_github::git+https://github.com/neilbrown/${_pkgname}.git"
"mdadm_gitkr::git://git.kernel.org/pub/scm/utils/mdadm/mdadm.git"
+ '0000-mdadm-no-build-on-install-test.patch'
"${_archlink//@@@/${_pkgname}.conf}"
#"${_archlink//@@@/${_pkgname}_hook}"
#"${_archlink//@@@/${_pkgname}_install}"
@@ -36,10 +41,12 @@ source=(
"${_pkgname}_udev_hook"
)
md5sums=('SKIP'
+ '074f72ac0367088920379c7e6b7e2a32'
'5a37c112aa07dccdde62f9fa5b888607'
'b6b0bfd6487c99264578630616dfe5eb'
'910398cd21e16c1da33f2d7449497245')
sha256sums=('SKIP'
+ '18f4ab16e9f4aed84d40456f6125fbb54447d0d0679d9b290355ff3acf8319a8'
'4ce1e90690282f98e4828e11576fbd61be65e97a2cdae6c7eac7035ea5ee53e5'
'170b0e5d548416c0adb9df4e6941bea6bc33d843419c997e45ecaf9e36a58f38'
'd395184617f45849cbbaf5b4ee3665ca6895a1d642e0470e9de703ce944279ca')
@@ -56,18 +63,20 @@ prepare() {
cd mdadm_git*/
# NB and the mdadm team strive for warning free code. Disable the warning only when necessary.
sed -e 's: -Werror : :g' -i 'Makefile' # disable-werror.patch
- sed -e 's:/usr/sbin/:/usr/bin:g' -e 's:/sbin:/usr/bin:g' -i 'Makefile' 'test' 'mkinitramfs' 'mdadm.conf.5'
+ sed -e 's:/usr/sbin/:/usr/bin:g' -e 's:/sbin:/usr/bin:g' -i $(grep -lrce '/sbin/' .)
+
+ # make install test must not compile anything
+ #f="${PWD##*/}"; cd ..; ln -sr "${f}" 'b'; cp -pr "${f}" a/; false
+ #diff -pNaru5 'a' 'b' > '0000-mdadm-no-build-on-install-test.patch'
+ patch -Nup1 -i "${srcdir}/0000-mdadm-no-build-on-install-test.patch"
- # make install must not compile anything
- sed -e '/^install\s*:/ s:\bmdadm mdmon\b::g' -i 'Makefile'
set +u
}
build() {
set -u
cd mdadm_git*/
- local _nproc="$(nproc)"; _nproc=$((_nproc>8?8:_nproc))
- nice make -s -j "${_nproc}" CXFLAGS="${CFLAGS}" BINDIR='/usr/bin' UDEVDIR='/usr/lib/udev'
+ nice make -s CXFLAGS="${CFLAGS}" BINDIR='/usr/bin' UDEVDIR='/usr/lib/udev'
set +u
}