summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSandy Carter2018-12-02 18:35:18 -0800
committerSandy Carter2018-12-02 18:35:18 -0800
commitbb66b26fbf9a3c40e80814b1376ef245e207d203 (patch)
tree63df75e376f415a10b3f51339080e36709d859cf /PKGBUILD
downloadaur-meson-cmake-wrapper-git.tar.gz
package init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b472fef2bd3c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+pkgname=meson-cmake-wrapper-git
+pkgver=r106.d09f2b0
+pkgrel=1
+pkgdesc="Build system wrapper that provides Meson integration in CMake IDE's."
+arch=('any')
+url="https://github.com/prozum/meson-cmake-wrapper"
+license=('MIT')
+depends=('python' 'meson' 'cmake')
+source=("git://github.com/prozum/meson-cmake-wrapper.git")
+sha256sums=("SKIP")
+
+pkgver() {
+ cd "${srcdir}/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${srcdir}/${pkgname%-git}"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et:
+