summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichel Zou2019-07-27 09:58:53 +0200
committerMichel Zou2019-07-27 09:58:53 +0200
commit8fd6f5d7aa3052761a9be0b8a70a748caabf9cc8 (patch)
treeccfc5460c1eb4697014f721835e53b6911f9df14 /PKGBUILD
downloadaur-mgard-git.tar.gz
init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a4ac858e296b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+pkgname=mgard-git
+pkgver=r79.11744c7
+pkgrel=1
+pkgdesc="MultiGrid Adaptive Reduction of Data"
+license=('Apache')
+arch=('x86_64')
+url="https://github.com/CODARcode/MGARD"
+depends=('blosc')
+makedepends=('cmake' 'git')
+provides=('mgard')
+conflicts=('mgard')
+source=("git+https://github.com/CODARcode/MGARD.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/MGARD"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd MGARD
+ mkdir -p build && cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_SKIP_INSTALL_RPATH=ON \
+ ..
+ make
+}
+
+package() {
+ cd MGARD/build
+ make DESTDIR="$pkgdir" install
+}
+