summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichel Zou2020-04-25 17:13:15 +0200
committerMichel Zou2020-04-25 17:13:15 +0200
commit8f726eaef1239fa88fddd7571d39ae41c3cab355 (patch)
tree488ca030d3dc5fe833fcf7f9562c7de8dacc625a /PKGBUILD
downloadaur-mingw-w64-ensmallen.tar.gz
2.12.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3db2380fc87e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+pkgname=mingw-w64-ensmallen
+pkgver=2.12.1
+pkgrel=1
+pkgdesc='Flexible C++ library for efficient mathematical optimization (mingw-w64)'
+arch=('any')
+url="https://ensmallen.org/"
+license=('BSD')
+depends=('mingw-w64-armadillo' 'mingw-w64-lapack')
+makedepends=('mingw-w64-cmake')
+options=('!buildflags' '!strip' 'staticlibs')
+source=("https://ensmallen.org/files/ensmallen-${pkgver}.tar.gz")
+sha256sums=('e91a7053b2db055c41c981753ce3aeb1afaabd10370a8c541ec04e1f4d07d964')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+prepare() {
+ cd "ensmallen-${pkgver}"
+}
+
+build() {
+ cd "ensmallen-${pkgver}"
+ for _arch in ${_architectures}; do
+ mkdir -p build-${_arch} && pushd build-${_arch}
+ ${_arch}-cmake \
+ -DBUILD_TESTS=OFF \
+ -DUSE_OPENMP=ON \
+ ..
+ make
+ popd
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd "$srcdir/ensmallen-${pkgver}/build-${_arch}"
+ make install DESTDIR="$pkgdir"
+ done
+}