summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTim Schumacher2019-04-28 10:14:48 +0200
committerTim Schumacher2019-04-28 10:16:54 +0200
commit5b9db9fc24a631a40ab7e2a2e3643d264ece0e41 (patch)
tree8aec65ad243513f77144943ba61bdcdac0260582 /PKGBUILD
parenta8aee190482f306725eec77f667e7a92feca82dc (diff)
downloadaur-mingw-w64-gcc-fs.tar.gz
Bring this up to par with mingw-w64-gcc 8.3.0-3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 22 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 929fc4349dc7..63e296374e98 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,9 +6,9 @@
_targets="i686-w64-mingw32 x86_64-w64-mingw32"
pkgname=mingw-w64-gcc-fs
-pkgver=8.2.0
-_islver=0.19
-pkgrel=1
+pkgver=8.3.0
+_islver=0.20
+pkgrel=3
pkgdesc="Cross GCC for the MinGW-w64 cross-compiler with builtin filesystem support"
arch=('x86_64')
url="http://gcc.gnu.org"
@@ -17,7 +17,6 @@ depends=('zlib' 'libmpc'
'mingw-w64-crt' 'mingw-w64-binutils' 'mingw-w64-winpthreads'
'mingw-w64-headers')
makedepends=("gcc-ada")
-#checkdepends=('dejagnu') # Windows executables could run on Arch through bin_mft and Wine
optdepends=()
provides=('mingw-w64-gcc-base' 'mingw-w64-gcc')
conflicts=('mingw-w64-gcc')
@@ -26,24 +25,34 @@ backup=()
options=('!strip' 'staticlibs' '!emptydirs' '!buildflags')
#source=(https://sources.archlinux.org/other/gcc/gcc-${pkgver/+/-}.tar.xz{,.sig}
source=(https://ftp.gnu.org/gnu/gcc/gcc-$pkgver/gcc-$pkgver.tar.xz{,.sig}
- "http://isl.gforge.inria.fr/isl-${_islver}.tar.bz2"
- gcc-filesystem.patch)
+ "http://isl.gforge.inria.fr/isl-${_islver}.tar.bz2" bz86593.patch gcc9-pr88568-2.patch
+ gcc-filesystem.patch)
validpgpkeys=(F3691687D867B81B51CE07D9BBE43771487328A9 # bpiotrowski@archlinux.org
13975A70E63C361C73AE69EF6EEB81F8981C74C7 # richard.guenther@gmail.com
33C235A34C46AA3FFB293709A328C3A2C3C45C06) # Jakub Jelinek <jakub@redhat.com>
-sha256sums=('196c3c04ba2613f893283977e6011b2345d1cd1af9abeac58e916b1aab3e0080'
+sha256sums=('64baadfe6cc0f4947a84cb12d7f0dfaf45bb58b7e92461639596c21e02d97d2c'
'SKIP'
- 'd59726f34f7852a081fbd3defd1ab2136f174110fc2e0c8d10bb122173fa9ed8'
- 'SKIP')
+ 'b587e083eb65a8b394e833dea1744f21af3f0e413a448c17536b5549ae42a4c2'
+ SKIP
+ SKIP
+ SKIP)
prepare() {
ln -sf gcc-${pkgver/+/-} gcc
- cd "$srcdir"/gcc
+ cd gcc
+
# link isl for in-tree builds
ln -sf ../isl-${_islver} isl
+ # https://gcc.gnu.org/bugzilla/show_bug.cgi?id=86593
+ rm -f gcc/testsuite/g++.dg/pr86593.C
+ patch -p1 -i "$srcdir/bz86593.patch"
+
+ # https://gcc.gnu.org/bugzilla/show_bug.cgi?id=88568
+ rm -f gcc/testsuite/g++.dg/other/pr88568.C
+ patch -p0 -i "$srcdir/gcc9-pr88568-2.patch"
+
# Fix up std::filesystem
- # TODO: Build a new version of this patch
patch -p1 -i "$srcdir"/gcc-filesystem.patch
}
@@ -59,7 +68,7 @@ build() {
--with-system-zlib --enable-cloog-backend=isl \
--enable-lto --disable-dw2-exceptions --enable-libgomp \
--disable-multilib --enable-checking=release --enable-libstdcxx-filesystem-ts=yes
- make all
+ make
done
}
@@ -78,6 +87,5 @@ package() {
strip "$pkgdir"/usr/bin/*
# remove unnecessary files
rm -r "$pkgdir"/usr/share
- rm -f "$pkgdir"/usr/lib/libcc1.so*
- rm -f "$pkgdir"/usr/lib/libcc1.a
+ rm "$pkgdir"/usr/lib/libcc1.*
}