summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichel Zou2023-08-26 09:40:33 +0200
committerMichel Zou2023-08-26 09:40:33 +0200
commit54dea38bf2b14928745e8d38deba3bd1b26eeb2f (patch)
treec64868afaf2962bd181922e61547edd691b72984 /PKGBUILD
parent3cca6110c106f3f59dd4e2c1332a79e5c18efaa2 (diff)
downloadaur-mingw-w64-json-c.tar.gz
0.17
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 5 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 203d91055932..281c53fbbc20 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,5 @@
-# Maintainer: Andrew Sun <adsun701 at gmail dot com>
-
pkgname=mingw-w64-json-c
-pkgver=0.15
+pkgver=0.17
pkgrel=1
pkgdesc="A JSON implementation in C (mingw-w64)"
arch=('any')
@@ -11,28 +9,22 @@ makedepends=('mingw-w64-cmake')
depends=('mingw-w64-crt')
options=('!strip' '!buildflags' 'staticlibs')
source=("https://github.com/json-c/json-c/archive/json-c-${pkgver//_/-}.tar.gz"
- "001-install-private-header.patch"
- "002-library-version.patch"
- "fix-snprintf.patch")
-sha256sums=('74985882e39467b34722e584ab836ed2abd47061888f318125fd4b167002afd5'
- '197e33a56fc3d655e058d6936e92698c8aa65b7297cb218345b8ad51350c4ecf'
- '2288c0ad1c0f98f2b43a8e4bdd09a6cf91710c7c8b1e7bf7a2b516ed21e81705'
- 'df185895f20f5591717daa6075c29a6b99b9dbcbc94e1b753689a8952cd95577')
+ "001-install-private-header.patch")
+sha256sums=('fc1b9ed57f4cda51c52ec9b3b012f6973bd8d80fb70f363c5ca2754342389eb1'
+ 'ac8c5c306bae8fc098c1420c78eab9c9d026f874614f24466987af5f30c70b20')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
prepare() {
cd "${srcdir}/json-c-json-c-${pkgver}"
patch -Np1 -i "${srcdir}/001-install-private-header.patch"
- patch -Np1 -i "${srcdir}/002-library-version.patch"
- patch -Np1 -i "${srcdir}/fix-snprintf.patch"
}
build() {
cd "${srcdir}/json-c-json-c-${pkgver}"
for _arch in ${_architectures}; do
mkdir -p build-${_arch} && pushd build-${_arch}
- ${_arch}-cmake -DBUILD_TESTING=OFF ..
+ ${_arch}-cmake -DBUILD_TESTING=OFF -DHAVE_SNPRINTF=1 ..
make
popd
done