summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartchus2022-05-18 18:06:59 +0200
committerMartchus2022-05-18 18:06:59 +0200
commitdc2069cee2f3bc7201ee53b51d3ade88380394df (patch)
tree56e0beb505ea19b54ef821b1cccc7bb2b7c94ac6 /PKGBUILD
parent21b61f9752047778eb821bc88e35bb0736f21dc0 (diff)
downloadaur-mingw-w64-kirigami2.tar.gz
Update to 5.94.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a093b30bca97..426dace7431f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
_pkgname=kirigami2
pkgname=mingw-w64-$_pkgname
-pkgver=5.60.0
+pkgver=5.94.0
pkgrel=1
pkgdesc="A QtQuick based components set (mingw-w64)"
arch=('any')
@@ -15,7 +15,7 @@ license=(LGPL)
depends=(mingw-w64-crt mingw-w64-qt5-quickcontrols mingw-w64-qt5-quickcontrols2 mingw-w64-qt5-graphicaleffects)
makedepends=(mingw-w64-gcc mingw-w64-cmake mingw-w64-extra-cmake-modules mingw-w64-qt5-tools mingw-w64-qt5-svg kpackage)
source=("https://download.kde.org/stable/frameworks/${pkgver%.*}/$_pkgname-$pkgver.tar.xz"{,.sig})
-sha256sums=('f016481d393041513dda11345e9ee84723587fa4be9f17391ed1a5868477e153'
+sha256sums=('d7f27da3325feb339f4e1a3db78df44f05e4f505f36e15c7caeac04da0428e39'
'SKIP')
validpgpkeys=('53E6B47B45CEA3E0D5B7457758D0EE648A48B3BB') # David Faure <faure@kde.org>
options=(!buildflags staticlibs !strip !emptydirs)
@@ -32,6 +32,10 @@ prepare() {
build() {
cd $_pkgname-$pkgver
for _arch in ${_architectures}; do
+ # workaround regression in CMake files of Qt (likely introduced by my patches)
+ for m in Gui Core; do
+ export CXXFLAGS+=" -I/usr/$_arch"/include/qt/Qt$m/$($_arch-qmake-qt5 -query QT_VERSION){/Qt$m,}
+ done
pushd "build-${_arch}"
${_arch}-cmake \
-DCMAKE_BUILD_TYPE=Release \