summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPatrick Northon2024-04-05 12:50:26 -0400
committerPatrick Northon2024-04-05 12:50:26 -0400
commitbd2091895395414424c8bb323dec64b7d1ce4be1 (patch)
tree776ac882e1f7dbbc8e65ac5aed3314e9d4f21524 /PKGBUILD
parentce65a38af3a456f5d01385f2a3b5c4845f9890a7 (diff)
downloadaur-mingw-w64-snappy.tar.gz
Prevent gtest from being installed.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 249ab7cdc29b..f17a83a94785 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_pkgname=snappy
pkgname=mingw-w64-${_pkgname}
pkgver=1.2.0
-pkgrel=1
+pkgrel=2
pkgdesc='A fast compressor/decompressor library (mingw-w64)'
arch=('any')
url="https://google.github.io/snappy/"
@@ -13,8 +13,9 @@ depends=('mingw-w64-crt')
makedepends=('mingw-w64-cmake' 'git')
checkdepends=('mingw-w64-wine' 'mingw-w64-zlib' 'mingw-w64-lzo' 'mingw-w64-lz4')
options=('!strip' '!buildflags' 'staticlibs')
-source=("git+https://github.com/google/snappy.git#tag=${pkgver}"
- 'git+https://github.com/google/googletest.git')
+source=(
+ "git+https://github.com/google/snappy.git#tag=${pkgver}"
+ 'git+https://github.com/google/googletest.git')
sha256sums=('99b5c9e017d904b88ce09369c0dd3fcaf07beaad49e3223d346e1fbcfcec3731'
'SKIP')
@@ -23,7 +24,9 @@ _architectures='i686-w64-mingw32 x86_64-w64-mingw32'
_flags=( -Wno-dev -DCMAKE_BUILD_TYPE='Release'
-DCMAKE_C_FLAGS_RELEASE='-DNDEBUG'
-DCMAKE_CXX_FLAGS_RELEASE='-DNDEBUG'
- -DSNAPPY_BUILD_BENCHMARKS=OFF )
+ -DCMAKE_CXX_STANDARD=23
+ -DSNAPPY_BUILD_BENCHMARKS=OFF
+ -DINSTALL_GTEST=OFF )
prepare() {
cd "${_srcdir}"