summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFabioLolix2022-04-13 17:34:54 +0200
committerFabioLolix2022-04-13 17:34:54 +0200
commit02cdb6ca60e58499a9be5f4e2cb2724b5cb0a698 (patch)
tree6efac1108f1561762df91d09e78565ac81496a5c /PKGBUILD
parent401659ffb94e3e021fc9ebeece9517fae6a714dd (diff)
downloadaur-minigalaxy-git.tar.gz
revision
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD54
1 files changed, 32 insertions, 22 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1fe16f5ba25f..33d2b6a43ab6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,45 @@
-# Maintainer: Joe Davison <joe@warhaggis.com>
+# Maintainer: Fabio 'Lolix' Loli <fabio.loli@disroot.org> -> https://github.com/FabioLolix
+# Contributor: Joe Davison <joe@warhaggis.com>
# Contributor: Wouter Wijsman <wwijsman@live.nl>
pkgname=minigalaxy-git
-pkgver=0.9.4.r66.gf7552ce
+pkgver=1.1.0.r91.g3882973
pkgrel=1
-pkgdesc="A simple GOG client for Linux, git version"
-provides=('minigalaxy')
-conflicts=('minigalaxy')
-arch=('any')
+pkgdesc="A simple GOG client for Linux"
+arch=(any)
url="https://github.com/sharkwouter/minigalaxy"
-license=('GPL-3')
-source=('git://github.com/sharkwouter/minigalaxy.git')
-md5sums=('SKIP')
-depends=('python' 'python-requests' 'python-gobject' 'gtk3' 'webkit2gtk')
-optdepends=('scummvm' 'dosbox' 'wine')
-makedepends=('python' 'python-setuptools' 'git')
+license=(GPL3 'CCPL:cc-by-sa-3.0')
+depends=(python python-requests python-gobject gtk3 webkit2gtk)
+makedepends=(python-setuptools git)
+checkdepends=(python-pytest python-simplejson)
+optdepends=('dosbox: Use the system DOSBox installation'
+ 'innoextract: Extract Windows installers'
+ 'scummvm: Use the system ScummVM installation'
+ 'wine: Install Windows games')
+provides=(minigalaxy)
+conflicts=(minigalaxy)
+source=("git+https://github.com/sharkwouter/minigalaxy.git")
+sha256sums=('SKIP')
pkgver() {
- git -C minigalaxy describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^wine.//;s/^v//;s/\.rc/rc/'
+ git -C minigalaxy describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^wine.//;s/^v//;s/\.rc/rc/'
}
build() {
- cd "$srcdir/${pkgname%-git}"
- rm -rf tests
- python setup.py build
+ cd "$srcdir/${pkgname%-git}"
+ python setup.py build
}
+
+check() {
+ cd "$srcdir/${pkgname%-git}"
+ pytest -v
+}
+
package() {
- cd "$srcdir/${pkgname%-git}"
- python setup.py install --root="$pkgdir" --prefix=/usr --skip-build
- install -D -m 644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- install -D -m 644 THIRD-PARTY-LICENSES.md "$pkgdir/usr/share/licenses/$pkgname/THIRD-PARTY-LICENSES.md"
- install -D -m 644 README.md "$pkgdir/usr/share/doc/$pkgname/README.md"
- install -D -m 644 CHANGELOG.md "$pkgdir/usr/share/doc/$pkgname/CHANGELOG.md"
+ cd "$srcdir/${pkgname%-git}"
+ python setup.py install --root="$pkgdir" --prefix=/usr --skip-build
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 THIRD-PARTY-LICENSES.md "$pkgdir/usr/share/licenses/$pkgname/THIRD-PARTY-LICENSES.md"
+ install -Dm644 README.md "$pkgdir/usr/share/doc/$pkgname/README.md"
+ install -Dm644 CHANGELOG.md "$pkgdir/usr/share/doc/$pkgname/CHANGELOG.md"
}