summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2022-08-19 23:52:51 -0300
committerDaniel Bermond2022-08-19 23:52:51 -0300
commit48e57e48b4cebc2808272b7cb3092251c211a743 (patch)
treea4d5989abf148b4a3b902fe1ac5a996cb7e9745e /PKGBUILD
parentfc67f2f98e560bc3b2b48b2b7dd7b4e31b505ac1 (diff)
downloadaur-mips64el-linux-gnu-binutils.tar.gz
Update to version 2.39
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 83b37bd81e5a..929d5ae6d52e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_target=mips64el-linux-gnu
pkgname="${_target}-binutils"
-pkgver=2.38
+pkgver=2.39
pkgrel=1
pkgdesc='Tools to assemble and manipulate binary and object files for the MIPS64EL target (for the toolchain with GNU C library and multilib ABI)'
arch=('x86_64')
@@ -12,15 +12,17 @@ depends=('libelf' 'zlib')
options=('!emptydirs' 'staticlibs' '!distcc' '!ccache')
_patchver='3dea562e9d615384cc5e786eff46ac1f8f41e18e'
source=("https://ftp.gnu.org/gnu/binutils/binutils-${pkgver}.tar.xz"{,.sig}
- "010-binutils-mips64-default-to-64-emulation-g${_patchver:0:7}.patch"::"https://raw.githubusercontent.com/openembedded/openembedded-core/${_patchver}/meta/recipes-devtools/binutils/binutils/0009-Change-default-emulation-for-mips64-linux.patch")
-sha256sums=('e316477a914f567eccc34d5d29785b8b0f5a10208d36bbacedcc39048ecfe024'
+ '010-binutils-mips64-default-to-64-emulation.patch')
+sha256sums=('645c25f563b8adc0a81dbd6a41cffbf4d37083a382e02d5d3df4f65c09516d00'
'SKIP'
- '2e0c71612d770d3b9531fa66211ac7ef810ddbe6253efe440ec1a069b08926b9')
+ '44e1420a85f0209d72e7e6595006066492dcc0accb0eb3ae416e2659ec3f224b')
validpgpkeys=('3A24BC1E8FB409FA9F14371813FCEF89DD9E3C4F') # Nick Clifton
prepare() {
mkdir -p build
- patch -d "binutils-${pkgver}" -Np1 -i "${srcdir}/010-binutils-mips64-default-to-64-emulation-g${_patchver:0:7}.patch"
+
+ # https://github.com/openembedded/openembedded-core/blob/yocto-3.4.4/meta/recipes-devtools/binutils/binutils/0009-Change-default-emulation-for-mips64-linux.patch
+ patch -d "binutils-${pkgver}" -Np1 -i "${srcdir}/010-binutils-mips64-default-to-64-emulation.patch"
}
build() {