summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTorsten Keßler2022-10-29 14:59:42 +0200
committerTorsten Keßler2022-10-29 14:59:42 +0200
commit7e015bedc95cdf2dd5fc7786a3a7a6ead51877ca (patch)
tree81fe736fc7585a79628dca9a805749032021205e /PKGBUILD
parente16df9ad92bf4e1fe365cf0215619a18f7e9a741 (diff)
downloadaur-mivisionx.tar.gz
upgpkg: mivisionx 5.3.0-1
* Follow cmake template from wiki * Update checksums
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 16 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1fe002dbddaa..c4d100decc30 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,38 +3,36 @@
# Contributer: JP-Ellis <josh@jpellis.me>
pkgname=mivisionx
-pkgver=5.2.1
+pkgver=5.3.0
pkgrel=1
pkgdesc="Set of comprehensive computer vision and machine intelligence libraries, utilities"
arch=('x86_64')
url="https://gpuopen-professionalcompute-libraries.github.io/MIVisionX/"
license=('MIT')
-depends=('rocm-core' 'rocm-cmake' 'miopengemm' 'miopen' 'protobuf' 'opencv' 'ffmpeg4.4' 'qt5-base')
-makedepends=('cmake')
+depends=('miopen-hip' 'migraphx' 'protobuf' 'opencv' 'ffmpeg4.4' 'qt5-base')
+makedepends=('rocm-cmake')
_git='https://github.com/GPUOpen-ProfessionalCompute-Libraries/MIVisionX'
source=("$pkgname-$pkgver.tar.gz::$_git/archive/rocm-$pkgver.tar.gz")
-sha256sums=('201996b31f59a8d5e4cc3f17d17a5b81158a34d2a1c833b65ccc3dceb21d176f')
+sha256sums=('58e68f1c78bbe5694e42bf61be177f9e94bfd3e0c113ec6284493c8684836c58')
options=(!lto)
_dirname="$(basename "$_git")-$(basename "${source[0]}" ".tar.gz")"
build() {
# -fcf-protection is not supported by HIP, see
- # https://docs.amd.com/bundle/ROCm-Compiler-Reference-Guide-v5.2/page/Appendix_A.html
+ # https://docs.amd.com/bundle/ROCm-Compiler-Reference-Guide-v5.3/page/Appendix_A.html
+ ROCM_PATH=/opt/rocm \
CXXFLAGS="${CXXFLAGS} -fcf-protection=none -isystem /usr/include/ffmpeg4.4" \
- cmake -B build -Wno-dev \
- -S "$_dirname" \
- -DCMAKE_INSTALL_PREFIX=/opt/rocm/mivisionx \
- -DBACKEND=HIP
- make -C build
+ cmake \
+ -Wno-dev \
+ -B build \
+ -S "$_dirname" \
+ -DCMAKE_INSTALL_PREFIX=/opt/rocm \
+ -DCMAKE_PREFIX_PATH=/opt/rocm \
+ -DBACKEND=HIP
+ cmake --build build
}
package() {
- DESTDIR="$pkgdir" make -C build install
-
- # add links
- install -d "$pkgdir/usr/bin"
- local _fn
- for _fn in mv_compile runvx; do
- ln -s "/opt/rocm/mivisionx/bin/$_fn" "$pkgdir/usr/bin/$_fn"
- done
+ DESTDIR="$pkgdir" cmake --install build
+ install -Dm644 "$_dirname/LICENSE.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}