summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorstefanwimmer1282023-05-03 20:18:33 +0200
committerstefanwimmer1282023-05-03 20:18:33 +0200
commita38d8a072d657ada7842e4ae0f6a86053917a7eb (patch)
tree6decb081ed9e537ec776b59a77cb64d50a1d0740 /PKGBUILD
parentd4fb21cbd3b9a16dc3246d96877fd73cda65fb66 (diff)
downloadaur-mksh-bin.tar.gz
Simplify PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2660290d81eb..09472d571094 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,23 @@
_pkgname=mksh
pkgname=$_pkgname-bin
-pkgver=59.c.r4
-pkgrel=1
+_pkgver=59.c-4
+pkgver=${_pkgver//-/.r}
+pkgrel=2
pkgdesc='MirBSD Korn Shell'
-arch=(x86_64)
+_arch=x86_64
+arch=($_arch)
license=(custom)
url='https://www.mirbsd.org/mksh.htm'
depends=('glibc')
provides=($_pkgname)
conflicts=($_pkgname)
-source=("$_pkgname-$pkgver.tar.zst::https://git.stefanwimmer128.eu/stefanwimmer128/mksh/-/package_files/67/download")
+source=("https://git.stefanwimmer128.io/api/v4/projects/163/packages/generic/$_pkgname/$_pkgver/$_pkgname-$_pkgver-$_arch.pkg.tar.zst")
sha256sums=('52ec23b52a8290e9eab1cc864bf7701492a29122e2ba5f86feb43540357ea3e4')
install=mksh.install
build() {
- rm "$_pkgname-$pkgver.tar.zst"
+ rm "$_pkgname-$_pkgver-$_arch.pkg.tar.zst"
rm .BUILDINFO .MTREE .PKGINFO .INSTALL
}