summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJonne Haß2020-10-28 11:56:24 +0100
committerJonne Haß2020-10-28 11:56:24 +0100
commit7bf37e5e320466b99f8b7434e1db251b9bd8eb73 (patch)
treec45d28c2f91bf98ed8dffa643f6db9b8a3b663a8 /PKGBUILD
parente0625a750c8e1738c7054ea6845e1306b4a991b3 (diff)
downloadaur-mlogtail-git.tar.gz
mlogtail-git: stdin tail patch
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 385e349b843a..e0a81cbe33e9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jonne Haß <me@jhass.eu>
pkgname=mlogtail-git
pkgver=r44.9c23c35
-pkgrel=1
+pkgrel=2
pkgdesc="Mail log tailing and simple stats collecting application"
arch=('any')
url="https://github.com/aadz/mlogtail"
@@ -9,13 +9,19 @@ license=('GPL')
makedepends=('git' 'go') # 'bzr', 'git', 'mercurial' or 'subversion'
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-source=('mlogtail::git+https://github.com/aadz/mlogtail.git')
+source=('mlogtail::git+https://github.com/aadz/mlogtail.git'
+ 'stdin_tail.patch::https://github.com/aadz/mlogtail/commit/2c46943f928529630d4c7c1ac5e2a0e2d56dec14.patch')
pkgver() {
cd "$srcdir/${pkgname%-git}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare() {
+ cd "$srcdir/${pkgname%-git}"
+ patch -p1 < "$srcdir/stdin_tail.patch"
+}
+
build() {
cd "$srcdir/${pkgname%-git}"
go get -u github.com/hpcloud/tail golang.org/x/sys/unix
@@ -26,4 +32,5 @@ package() {
cd "$srcdir/${pkgname%-git}"
install -Dm755 mlogtail "$pkgdir/usr/bin/mlogtail"
}
-sha256sums=('SKIP')
+sha256sums=('SKIP'
+ '715c763856b5aa86d9c18c360a478d2e616656a63dc6160f6c281eec24c21731')