summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoreveryx2023-06-27 14:24:29 +0800
committereveryx2023-06-27 14:24:29 +0800
commitfd5dab7c20ab366603046252b3eaa224041af044 (patch)
tree5d5ca0623f67e961df43db5d4307456b07c4a677 /PKGBUILD
parenta59d5f44c1fc38f9611901c24a33ac23003b2c9d (diff)
downloadaur-mockplus-dt-font-agent-bin.tar.gz
fix: provide user unit only
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 3 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 81ab5ee88b4a..8b201abc13c8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=mockplus-dt-font-agent
pkgname=${_pkgname}-bin
pkgver=1.0.2
-pkgrel=2
+pkgrel=3
pkgdesc="Mockplus DT - Font Agent"
arch=("any")
url="https://www.mockplus.cn/dt"
@@ -16,15 +16,10 @@ sha512sums=("7223c1594ac223c3232fa2548a56b54d471d580e0b9b723b8a62a0f63f98ca48651
_user=mockplus
build(){
- sed -i -e "s|^ExecStart=.*$|ExecStart=/usr/bin/DTFontAgent \&|;
- /^\[Service\]$/a User=$_user" \
- DTFontAgent.service
-
- echo "u $_user - \"Mockplus Service\" - -" > "$_user.conf"
+ sed -i 's|/usr/local/bin/|/usr/bin/|' DTFontAgent.service
}
package() {
install -Dm755 DTFontAgent -t "$pkgdir/usr/bin/"
- install -Dm644 DTFontAgent.service -t "$pkgdir/usr/lib/systemd/system/"
- install -Dm644 $_user.conf -t "$pkgdir/usr/lib/sysusers.d/"
+ install -Dm644 DTFontAgent.service -t "$pkgdir/usr/lib/systemd/user/"
}