summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDavid2024-02-12 14:37:22 +0100
committerDavid2024-02-12 14:37:22 +0100
commitad8e03ecb3693dae21d4a10e8442443b867115f4 (patch)
treeb22487624ae4e190285fec49ee3769c3b1a86917 /PKGBUILD
parent16826e2f14f636400126ed053277600fd7099bf5 (diff)
downloadaur-mod-desktop-network-bin.tar.gz
Remove sudo requirement from PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fa52e0868468..e598f41e1409 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=mod-desktop-network-bin
provides=(${pkgname//-network-bin/""})
pkgver=0.0.10
-pkgrel=2
+pkgrel=3
pkgdesc="MOD Desktop Application with network access to mod-ui"
arch=('x86_64')
url="https://github.com/moddevices/mod-desktop"
@@ -27,6 +27,6 @@ package() {
install -Dm644 "$provides-$pkgver-linux-$arch/mod-desktop.desktop" "$pkgdir/usr/share/applications/$provides.desktop"
# Network access patch
- sudo sed -i 's/application.listen(DEVICE_WEBSERVER_PORT, address=("127.0.0.1" if DESKTOP else "0.0.0.0"))/application.listen(DEVICE_WEBSERVER_PORT, address=("0.0.0.0"))/' "$pkgdir/opt/$provides/mod/webserver.py"
+ sed -i 's/application.listen(DEVICE_WEBSERVER_PORT, address=("127.0.0.1" if DESKTOP else "0.0.0.0"))/application.listen(DEVICE_WEBSERVER_PORT, address=("0.0.0.0"))/' "$pkgdir/opt/$provides/mod/webserver.py"
}