summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorElisamuel Resto2022-04-26 00:39:31 -0500
committerElisamuel Resto2022-04-26 00:39:31 -0500
commit04344c913f742d291bf56dae15eef4a6ce81ddf0 (patch)
tree4d68466fe2b5b720454523501f34aa76e77ee2c8 /PKGBUILD
parent65cdc3ae5bff6c321fe489557e69733345b61117 (diff)
downloadaur-mod_authnz_pam.tar.gz
Updated to 1.2.3
Signed-off-by: Elisamuel Resto <sam@samresto.dev>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3fee67ed38ad..84ae969e1fac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
-# Maintainer: Carlos Silva <r3pek@r3pek.org>
+# Maintainer: Elisamuel Resto <sam@samresto.dev>
+# Contributor: Carlos Silva <r3pek@r3pek.org>
pkgname=mod_authnz_pam
-pkgver=1.2.0
+pkgver=1.2.3
pkgrel=1
pkgdesc="Apache module to run PAM authorization on result of other module's authentication; also full Basic Auth PAM provider."
arch=('i686' 'x86_64')
@@ -11,15 +12,15 @@ depends=('apache'
'pam')
makedepends=('pkgconfig')
source=("https://github.com/adelton/mod_authnz_pam/archive/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('2d0056aefc394607bcdaaa53638c09c100ebd10faaab7cfef29553bfd60b8892')
+sha256sums=('43151a8e1d298729c27742978821cee101c58b15c5880ef54e1982381b6c588f')
build() {
- cd "${pkgname}-${pkgver}"
+ cd "${pkgname}-${pkgname}-${pkgver}"
apxs -c mod_authnz_pam.c -lpam -Wall -pedantic
}
package() {
- cd "${pkgname}-${pkgver}"
+ cd "${pkgname}-${pkgname}-${pkgver}"
APACHE_MOD_DIR=$(apxs -q libexecdir)
install -D -m755 .libs/mod_authnz_pam.so ${pkgdir}/${APACHE_MOD_DIR}/mod_authnz_pam.so