summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichal Wojdyla2020-10-30 23:08:24 +0100
committerMichal Wojdyla2020-10-30 23:08:24 +0100
commit868ae57550fb773c3e9088041d47ab433789a80a (patch)
treec63297336a6302a09f0a5d611a1a92bdc08c523d /PKGBUILD
parent7d11cc11a1c44853279834586488f4b7e82d2ecf (diff)
downloadaur-mod_python2.tar.gz
update to same commit as mod_python
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1b5a0616d2fa..d8698bca549f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
-# Maintainer: Allen Zhong <moeallenz@gmail.com>
+# Contributor: Michal Wojdyla < micwoj9292 at gmail dot com >
+# Contributor: Allen Zhong <moeallenz@gmail.com>
# Contributor: Jonathan Liu <net147@gmail.com>
-
+_hash=8fb45feab94152a6aae3492aed4b81c363a912bd
pkgname=mod_python2
pkgver=3.5.0
-pkgrel=2
+pkgrel=3
pkgdesc="An Apache module that embeds the Python2 interpreter within the server"
arch=('i686' 'x86_64')
url="http://www.modpython.org/"
@@ -11,12 +12,12 @@ license=('APACHE')
depends=('apache' 'python2')
conflicts=('mod_python2-legacy' 'mod_python')
install="mod_python.install"
-source=("http://dist.modpython.org/dist/mod_python-$pkgver.tgz")
+source=(mod_python-$_hash.zip::https://github.com/grisha/mod_python/archive/$_hash.zip)
options=('!strip')
-md5sums=('2e61621e8d030f535f112d8e739161e2')
+md5sums=('e918cb1141d17aa754d1a51cbd458112')
build() {
- cd "$srcdir/mod_python-$pkgver"
+ cd "$srcdir/mod_python-$_hash"
sed -i -e "s#git describe --always#echo $pkgrel#" dist/version.sh
./configure --prefix=/usr --with-python=/usr/bin/python2
sed -i -e "s#-Wl[^ ]*#$LDFLAGS#g" src/Makefile
@@ -24,7 +25,7 @@ build() {
}
package() {
- cd "$srcdir/mod_python-$pkgver"
+ cd "$srcdir/mod_python-$_hash"
install -d "$pkgdir"/usr/bin
make DESTDIR="$pkgdir" install
}