summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAdam S Levy2018-03-18 23:40:18 -0800
committerAdam S Levy2018-03-18 23:40:18 -0800
commit444bb0d8817453a71cea613865fa5bbfaff2f26d (patch)
treee2127697155a96b843fc2626c0e13ab9df7e13ab /PKGBUILD
downloadaur-444bb0d8817453a71cea613865fa5bbfaff2f26d.tar.gz
Initial commit version 3.4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 18 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3845cb6e64f0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Adam S Levy <adam@aslevy.com>
+pkgname=modpoll-bin
+_pkgname=modpoll
+pkgver=3.4
+pkgrel=1
+pkgdesc="A command line based Modbus master simulator and test utility."
+arch=("x86_64")
+url="https://www.modbusdriver.com/$_pkgname.html"
+license=('custom')
+provides=("$_pkgname")
+source=("https://www.modbusdriver.com/downloads/$_pkgname.$pkgver.zip")
+md5sums=('af5953808212e005b458ca90d7cf868b')
+
+package() {
+ cd "$srcdir"
+ install -Dm755 linux/$_pkgname "$pkgdir/usr/bin/$_pkgname"
+ install -Dm644 LICENSE-FREE "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
+}