summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorluozhiya2024-08-17 14:52:52 +0800
committerluozhiya2024-08-17 14:52:52 +0800
commit1baaacd5bf35010cba08a561c937c86188c6146b (patch)
treebd9cf70ca84b9fa65c644f54bb4c6d4dda556338 /PKGBUILD
parentadb476b7af7edb1508439e6d97e77a53beb5f7e8 (diff)
downloadaur-mogan-git.tar.gz
bump to v1.2.8
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d568cf9f967b..554f3ca40907 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,10 @@ pkgdesc="A structured wysiwyg scientific text editor"
arch=("x86_64")
url="https://github.com/XmacsLabs/mogan"
license=("GPL3")
-depends=("qt5-base" "qt5-svg" "qt6-base" "qt6-svg" "sqlite" "zlib" "unzip" "curl" "texlive-core" "python" "libxext" "libgit2")
+depends=(
+ "qt6-base" "qt6-svg" "noto-fonts-cjk" "libpng" "libjpeg" "sqlite"
+ "zlib" "unzip" "curl" "texlive-core" "python" "libxext" "libgit2"
+ "mimalloc" "fontconfig" "freetype2" "openssl")
makedepends=("git" "xmake")
optdepends=(
"gawk: Conversion of some files"
@@ -28,7 +31,8 @@ prepare() {
build() {
cd "${pkgname}"
xmake repo --update --yes
- xmake config -vD --policies=build.ccache -m releasedbg --yes
+ QT6_VERSION=$(qmake6 -query QT_VERSION)
+ xmake config -vD --policies=build.ccache -m releasedbg --yes --qt_sdkver=${QT6_VERSION}
xmake build --yes -vD research
}