summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDrRac272024-01-04 13:25:32 +0100
committerDrRac272024-01-04 13:25:32 +0100
commit7cd4e5105e08b27d14263717c24a12f497e3fc58 (patch)
tree078ac4290d2e043406d64bffbd9427982a585360 /PKGBUILD
parentee69b364c76b6046f57f79efd9e905bce74dd815 (diff)
downloadaur-moment-git.tar.gz
update to v0.7.4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD103
1 files changed, 52 insertions, 51 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ecf72ea74a74..ab7f9057c76c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,51 +2,52 @@
pkgname=moment-git
_name=moment
-pkgver=v0.7.3.r32.2af33fce
+pkgver=v0.7.4.r0.fb4501e9
pkgrel=1
pkgdesc='A customizable, keyboard-operable Matrix client. Fork of Mirage'
arch=('x86_64' 'i686' 'aarch64')
url='https://mx-moment.xyz/'
license=('LGPL3')
depends=(
- 'qt5-base'
- 'qt5-declarative'
- 'qt5-quickcontrols2'
- 'qt5-svg'
- 'qt5-graphicaleffects'
- 'qt5-imageformats'
- 'python'
- 'python-pyotherside'
- 'libolm'
- 'libjpeg-turbo'
- 'zlib'
- 'libtiff'
- 'libwebp'
- 'openjpeg2'
- 'libmediainfo'
- 'python-pillow'
- 'python-pymediainfo'
- 'python-cairosvg'
- 'python-aiofiles'
- 'python-appdirs'
- 'python-filetype'
- 'python-html-sanitizer'
- 'python-lxml'
- 'python-mistune>=2'
- 'python-matrix-nio'
- 'libxss'
- 'python-plyer'
- 'python-sortedcontainers'
- 'python-watchgod'
- 'python-redbaron'
- 'dbus-python'
- 'python-hsluv'
- 'python-pycryptodome'
- 'python-simpleaudio'
- 'python-olm'
- 'python-cachetools'
- 'python-atomicwrites'
- 'python-peewee'
+ 'qt5-base'
+ 'qt5-declarative'
+ 'qt5-quickcontrols2'
+ 'qt5-svg'
+ 'qt5-graphicaleffects'
+ 'qt5-imageformats'
+ 'python'
+ 'python-pyotherside'
+ 'libolm'
+ 'libjpeg-turbo'
+ 'zlib'
+ 'libtiff'
+ 'libwebp'
+ 'openjpeg2'
+ 'libmediainfo'
+ 'python-pillow'
+ 'python-pymediainfo'
+ 'python-cairosvg'
+ 'python-aiofiles'
+ 'python-appdirs'
+ 'python-filetype'
+ 'python-html-sanitizer'
+ 'python-lxml'
+ 'python-mistune>=2'
+ 'python-matrix-nio'
+ 'libxss'
+ 'python-plyer'
+ 'python-sortedcontainers'
+ 'python-watchgod'
+ 'python-redbaron'
+ 'dbus-python'
+ 'python-emoji'
+ 'python-hsluv'
+ 'python-pycryptodome'
+ 'python-simpleaudio'
+ 'python-olm'
+ 'python-cachetools'
+ 'python-atomicwrites'
+ 'python-peewee'
)
makedepends=('cmake' 'git')
provides=('moment')
@@ -55,25 +56,25 @@ source=('git+https://gitlab.com/mx-moment/moment.git')
sha256sums=('SKIP')
prepare() {
- cd "${srcdir}/${_name}"
- git submodule update --init --recursive
+ cd "${srcdir}/${_name}"
+ git submodule update --init --recursive
}
pkgver() {
- cd "${srcdir}/${_name}"
- local tag=$(git tag --sort=-v:refname | head -1)
- local commits_since=$(git rev-list $tag..HEAD --count)
- echo "$tag.r$commits_since.$(git log --pretty=format:'%h' -n 1)"
+ cd "${srcdir}/${_name}"
+ local tag=$(git tag --sort=-v:refname | head -1)
+ local commits_since=$(git rev-list $tag..HEAD --count)
+ echo "$tag.r$commits_since.$(git log --pretty=format:'%h' -n 1)"
}
build() {
- cd "${srcdir}/${_name}"
- make clean || true
- qmake PREFIX=/usr moment.pro
- make
+ cd "${srcdir}/${_name}"
+ make clean || true
+ qmake PREFIX=/usr moment.pro
+ make
}
package() {
- cd "${srcdir}/${_name}"
- make INSTALL_ROOT="${pkgdir}" install
+ cd "${srcdir}/${_name}"
+ make INSTALL_ROOT="${pkgdir}" install
}