summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorIsaak Eriksson2020-12-13 14:52:47 +0100
committerIsaak Eriksson2020-12-13 14:54:29 +0100
commit8e75b21b9a3583290657c610231918de4aa2d02c (patch)
tree6572b7694b36a6717ad59625d1d3c5c5db61bde9 /PKGBUILD
downloadaur-mongocli-bin.tar.gz
Create initial PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e87bdc46f76b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Isaak Eriksson <isaak.eriksson@protonmail.com>
+
+pkgname=mongocli-bin
+pkgver=1.9.0
+pkgrel=1
+pkgdesc="mongocli binary to deploy and manage Atlas clusters"
+arch=("x86_64")
+url="https://docs.mongodb.com/mongocli/master/"
+license=("SSPLv1")
+provides=("mongocli=$pkgver")
+source=("https://github.com//mongodb/mongocli/releases/download/v${pkgver}/mongocli_${pkgver}_linux_x86_64.tar.gz")
+sha256sums=('bb745cd35cd96567e25db9eea6033512e67cc0a4e70fe54e88c73bc01cde4142')
+
+prepare() {
+ cd "${srcdir}"
+ tar -xvf "mongocli_${pkgver}_linux_x86_64.tar.gz"
+}
+
+package() {
+ mkdir -p "$pkgdir/usr/bin/"
+ cp "$srcdir/mongocli_${pkgver}_linux_x86_64/mongocli" "$pkgdir/usr/bin/"
+ install -Dm644 "$srcdir/mongocli_${pkgver}_linux_x86_64/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim: set tabstop=4 shiftwidth=2 expandtab: