summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexander Beck2024-03-29 20:40:02 +0100
committerAlexander Beck2024-03-29 20:40:02 +0100
commitd6f1313c1aff81831ae911cdd6fab735b683ace0 (patch)
treededd064656164d82d1c1692cf9f4e610eda6091b /PKGBUILD
parent2df577c2b5928ad114c7e1a1bd1b6985650d5da6 (diff)
downloadaur-monocle.tar.gz
Update to v0.5.5
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 8 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index efb332ec5e5e..c148471cf179 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Alexander Beck <dev@daallexx.eu>
pkgname=monocle
-pkgver=0.5.4
+pkgver=0.5.5
pkgrel=1
pkgdesc='See through all BGP data with a monocle'
arch=('x86_64')
@@ -9,37 +9,32 @@ url='https://github.com/bgpkit/monocle'
license=('MIT')
depends=('gcc-libs' 'openssl')
makedepends=('cargo' 'cmake')
-source=(
- "$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz"
-)
-sha512sums=(
- '79183dc3bb799cc518923bc8f292aa41a2d0afa36bde3fb28cb04d33c2b1bf3439da8c3c986559c90a2250c1c91da03a5554e32cbbfc9fef311973ecbffebf58'
-)
+source=("git+https://github.com/bgpkit/monocle#tag=v${pkgver}")
+sha512sums=('4d046c5cb98c8fa627a5ac08acb787cf382d98f9f7d5337840d4f8bedfce4dffdd57831b529f129ad257f8af25f1ff33ae622666bd0cdd7f4dd02617e96c6665')
options=(!debug !lto)
prepare() {
- cd "$pkgname-$pkgver"
+ cd "$pkgname"
export RUSTUP_TOOLCHAIN=stable
- cargo update
- cargo fetch --locked --target "$(rustc -vV | sed -n 's/host: //p')"
+ cargo fetch --target "$(rustc -vV | sed -n 's/host: //p')"
}
build() {
- cd "$pkgname-$pkgver"
+ cd "$pkgname"
export RUSTUP_TOOLCHAIN=stable
export CARGO_TARGET_DIR=target
cargo build --frozen --release --all-features
}
check() {
- cd "$pkgname-$pkgver"
+ cd "$pkgname"
export RUSTUP_TOOLCHAIN=stable
cargo test --frozen --all-features
}
package() {
- cd "$pkgname-$pkgver"
+ cd "$pkgname"
install -Dm 755 "target/release/$pkgname" -t "$pkgdir/usr/bin"
install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname"
install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"