summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAdriĆ  Arrufat2015-07-15 19:46:30 +0200
committerAdriĆ  Arrufat2015-07-15 19:46:30 +0200
commited4251e08a04495ff3fb15e2f8d2169733abc1fa (patch)
tree99e3882d140664bf748ddedc67c357371ecd7d05 /PKGBUILD
downloadaur-mpdris.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d5d75ae6763c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Contributor: Adria Arrufat <swiftscythe@gmail.com>
+pkgname=mpdris
+pkgver=0.1.2
+pkgrel=2
+pkgdesc="An implementation of the XMMS2 media player interface MPRIS as a client for MPD"
+arch=('i686' 'x86_64')
+url="http://ayeon.org/projects/mpDris/"
+license=('GPL')
+depends=('dbus-python>=0.80' 'pygobject>=2.14' 'python2-mpd>=0.2.0')
+optdepends=('mpd: the Music Player Daemon')
+makedepends=('subversion')
+backup=(etc/mpDris.conf)
+source=('http://ayeon.org/projects/mpDris/mpDris-0.1.2.tar.bz2')
+md5sums=('c4b94b119592474e387f8a988f6ce7d3')
+
+build() {
+ cd "$srcdir/mpDris-$pkgver"
+
+ python2 setup.py install --root=$pkgdir
+ sed "1s/python/&2/" $pkgdir/usr/bin/mpDris
+ install -m 0644 -D mpDris.conf $pkgdir/etc/mpDris.conf
+}