summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMagnus Boman2020-08-03 01:19:19 +0200
committerMagnus Boman2020-08-03 01:19:19 +0200
commit08774bbaefd4c7530342c5050cdc60cc85bd1106 (patch)
tree9923937f4428747b817a18bc02522aa611da6f4f /PKGBUILD
downloadaur-mpv-webm-bin-git.tar.gz
mpv-webm-bin-git: add package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cf51b2922b62
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: katt <magunasu.b97@gmail.com>
+
+pkgname=mpv-webm-bin-git
+pkgver=r86.13f93e8
+pkgrel=1
+pkgdesc='Simple WebM maker for mpv'
+arch=(any)
+url=https://github.com/ekisu/mpv-webm
+license=(MIT)
+depends=(mpv)
+makedepends=(git)
+provides=("${pkgname%-bin-git}")
+conflicts=("${pkgname%-bin-git}")
+source=(git+"${url}".git)
+md5sums=(SKIP)
+
+pkgver() {
+ cd "${pkgname%-bin-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ install -Dm644 "${pkgname%-bin-git}/build/webm.lua" -t "$pkgdir/usr/lib/mpv"
+ install -Dm644 "${pkgname%-bin-git}/LICENSE" -t "$pkgdir/usr/share/licenses/$pkgname"
+}