summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorArctic Ice Studio2018-04-10 22:01:30 +0200
committerArctic Ice Studio2018-04-10 22:01:30 +0200
commitdf374387c8fcabf53331fcf5671c16f14815705d (patch)
tree0d7b23bb8da732ba38c3ad9ee2588b080403403f /PKGBUILD
parent7945a2997e700dcd2133a16829ab763835e94761 (diff)
downloadaur-df374387c8fcabf53331fcf5671c16f14815705d.tar.gz
Update to latest upstream version 1.7.0
The .deb source file is packaged using another packager tool instead of install4j. It comes with a bundled JRE Java runtime so the dependency to the metagroup "java-runtime" is currently not necessary anymore. The bundled JRE should be used until the compability with the latest JRE 9/10 version has been approved. Another change is that the application icon is not bundled anymore so it has been added to the package itself. The also .deb file uses another format resulting in a "data.tar.xz" archive instead "data.tar.gz" so the "z" flag of "tar" has been changed to "J" to use "ar x <NAME>.deb" and "unxz" to uncompress the file and data archive.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 12 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cac86490abee..dfd68bc32eab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,33 +2,35 @@
# Contributor: Arctic Ice Studio <development@arcticicestudio.com>
pkgname=mqttfx-bin
_pkgbasename=mqttfx
-pkgver=1.6.0
-pkgrel=2
+pkgver=1.7.0
+pkgrel=1
pkgdesc="A MQTT Client written in Java based on Eclipse Paho"
arch=("x86_64")
url="http://mqttfx.org"
license=("Apache")
-depends=("java-runtime" "java-openjfx")
options=("!strip" "!upx")
source=(
- "http://www.jensd.de/apps/${_pkgbasename}/${pkgver}/${_pkgbasename}-${pkgver}-linux.deb"
- "${_pkgbasename}.desktop")
+ "http://www.jensd.de/apps/${_pkgbasename}/${pkgver}/${_pkgbasename}-${pkgver}-64bit.deb"
+ "${_pkgbasename}.desktop"
+ "${_pkgbasename}.png"
+)
sha256sums=(
- "2a4f11f1a599471be34486a6e7443052dd0548ba5750ef380c81bdfb4efdcef9"
- "27abc38d59d94d1d8e8e171d1d15d392fd65774d89235be734145ae4c50c6c0b"
+ "06153aa3176e74ee8e8d5995ff6f9b74bc57327987f934a7b1688a30fcdc5a3f"
+ "741674f5b782aa4de0b071b7f49484b74ee2150e38b5d83eb4bd00b172978e2a"
+ "6c1b23755d3b1832ddb643b585d623128cde38e2ef42e7839141cf2106b0a59e"
)
package() {
cd "${srcdir}"
# Extract the application data into the package directory root
- tar -xzf data.tar.gz -C "${pkgdir}"
+ tar -xJf data.tar.xz -C "${pkgdir}"
# Install the binary directory and link into package
install -dm755 "${pkgdir}/usr/bin"
ln -s "/opt/${_pkgbasename}/${_pkgbasename}" "${pkgdir}/usr/bin/${_pkgbasename}"
- # Install the application logo icon and desktop launcher
- install -Dm644 "${pkgdir}/opt/${_pkgbasename}/.install4j/${_pkgbasename}.png" "${pkgdir}/usr/share/icons/hicolor/128x128/apps/${_pkgbasename}.png"
+ # Install the application logo and desktop launcher
+ install -Dm644 "${_pkgbasename}.png" "${pkgdir}/usr/share/icons/hicolor/128x128/apps/${_pkgbasename}.png"
install -Dm644 "${_pkgbasename}.desktop" "${pkgdir}/usr/share/applications/${_pkgbasename}.desktop"
}