summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsoenke2019-12-13 01:41:32 +0100
committersoenke2019-12-13 01:41:32 +0100
commitfc9abc744338a7090917d86e27472fcf42d53c78 (patch)
tree09ac8e825fea01afac431d13bc41c86a7ef818a7 /PKGBUILD
parentc254009aa858223971c4ea3bded5f20390ea44cb (diff)
downloadaur-mrpt.tar.gz
updated to 1.5.8 and added patches if boath opencv and opencv2-opt are installed
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 11 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3b3183d0e0b5..3b03a8029b65 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=mrpt
-pkgver=1.5.6
+pkgver=1.5.8
pkgrel=1
pkgdesc="Provides an extensive set of libraries, algorithms, and applications employed in a number of mobile robotics research areas."
arch=('i686' 'x86_64' 'armv7h')
@@ -16,15 +16,22 @@ _dir=${pkgname}-${pkgver}
_tag=${pkgver}
source=("${_dir}"::"git+https://github.com/MRPT/mrpt.git"#tag=${_tag}
"https://raw.githubusercontent.com/majorx234/mrpt_patch/master/mrpt_CmakeLists.patch"
- "https://raw.githubusercontent.com/majorx234/FindNumPy.cmake/master/FindNumPy.cmake")
+ "https://raw.githubusercontent.com/majorx234/FindNumPy.cmake/master/FindNumPy.cmake"
+ "opencv_and_opencv2-opt.patch"
+ "prevent_gtk3_linking.patch")
+
sha256sums=('SKIP'
'ec4f93431c098ef2515f6bb10358cb17dd3c804ebb295285792ad62f0826ab32'
- 'e8cbe6841595d594659d9a16464af2386efd0dce2947e8f348e2c47fad1d022f')
-
+ 'e8cbe6841595d594659d9a16464af2386efd0dce2947e8f348e2c47fad1d022f'
+ 'SKIP'
+ 'SKIP')
+
prepare() {
cp ${srcdir}/FindNumPy.cmake ${srcdir}/$pkgname-$pkgver/cmakemodules/
cd "${srcdir}/$pkgname-$pkgver"
patch -Np1 -i "${srcdir}/mrpt_CmakeLists.patch"
+ patch -Np1 -i "${srcdir}/opencv_and_opencv2-opt.patch"
+ patch -Np1 -i "${srcdir}/prevent_gtk3_linking.patch"
}
build() {