summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDavid Rosenstrauch2015-07-21 23:09:19 -0400
committerDavid Rosenstrauch2015-07-21 23:09:19 -0400
commit35563068fac02c31d7192c27835d22e6c0b0395c (patch)
treee641de5f2343256713933760007030854364aebd /PKGBUILD
downloadaur-mrunit.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 17 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5b787f22001b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: David Rosenstrauch <darose@darose.net>
+pkgname=mrunit
+pkgver=1.0.0
+_pkgverfull=1.0.0-hadoop2
+pkgrel=1
+pkgdesc="Apache MRUnit is a Java library that helps developers unit test Apache Hadoop map reduce jobs"
+arch=('any')
+url="http://mrunit.apache.org/"
+license=('apache')
+depends=('mockito')
+source=(http://mirror.cc.columbia.edu/pub/software/apache/$pkgname/$pkgname-$pkgver/apache-$pkgname-$_pkgverfull-bin.tar.gz)
+md5sums=('a942422d1677c12f0ed5444d08e6f023')
+
+package() {
+ cd "$srcdir/apache-$pkgname-$_pkgverfull"
+ install -Dm644 ${srcdir}/apache-$pkgname-$_pkgverfull/lib/${pkgname}-${_pkgverfull}.jar ${pkgdir}/usr/share/java/${pkgname}.jar
+}