summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorScias2018-04-02 23:07:47 +0200
committerScias2018-04-02 23:07:47 +0200
commit4640420a64348a9099564ecd95161ab38d3012a9 (patch)
tree0f577d62bee453347aea420ad9a30c567eca8b8a /PKGBUILD
downloadaur-msi-rgb.tar.gz
Initial release on AUR
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..02dd2529f786
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Scias < shining -dot- scias \at\ gmail #dot# com>
+pkgname=msi-rgb
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Utility for controlling the RGB LEDs on MSI motherboards"
+arch=('i686' 'x86_64')
+url="https://github.com/nagisa/msi-rgb"
+license=('ISC')
+makedepends=('rust')
+source=("$pkgname"::'git+https://github.com/nagisa/msi-rgb')
+md5sums=('SKIP')
+
+build() {
+ cd "$pkgname"
+ cargo build --release
+}
+
+package() {
+ mkdir -p "$pkgdir/usr/bin"
+ cp "$pkgname/target/release/msi-rgb" "$pkgdir/usr/bin"
+}